Perl 6 - the future is here, just unevenly distributed

IRC log for #openframeworks, 2014-02-06

| Channels | #openframeworks index | Today | | Search | Google Search | Plain-Text | summary

All times shown according to UTC.

Time Nick Message
00:09 robot joined #openframeworks
00:54 pizthewiz joined #openframeworks
01:02 finger563 joined #openframeworks
01:08 admsyn joined #openframeworks
01:09 lmccart joined #openframeworks
01:32 lmccart_ joined #openframeworks
01:35 lmccart joined #openframeworks
02:07 admsyn joined #openframeworks
02:19 nicedice joined #openframeworks
03:19 pizthewiz joined #openframeworks
03:57 finger563 wohoo!
03:57 finger563 :)
03:58 finger563 @jvcleave I'm 99% to having working h264 encoded video output from my shaders :D
04:23 finger563 i.e. i have vide encoding working from a separate thread which reads from a circular buffer written to by the update code.  The video works, just my encodingof u,v are a little off :P
04:24 admsyn \o\ /o/
04:24 finger563 haha
04:40 davidnunez joined #openframeworks
05:41 boltR joined #openframeworks
06:22 pizthewiz joined #openframeworks
07:05 ramzes joined #openframeworks
07:11 GuidovanPossum joined #openframeworks
07:26 ncls joined #openframeworks
07:41 ofarturo joined #openframeworks
07:54 LCID_Fire joined #openframeworks
09:21 LCID_Fire joined #openframeworks
09:39 andreas_ joined #openframeworks
10:06 robot joined #openframeworks
10:17 robo joined #openframeworks
10:20 nylki_ joined #openframeworks
10:28 robot joined #openframeworks
10:46 neue joined #openframeworks
11:57 Joel_re joined #openframeworks
11:57 Joel_re hey
11:57 Joel_re Im about to get my hands on a kinect to begin developing on Openframeworks
11:57 Joel_re I read that I need to find a model older than 1414 ?
11:57 Joel_re as per https://github.com/openframeworks/openF​rameworks/tree/master/addons/ofxKinect
11:58 Joel_re or what should I be worried about
11:58 Joel_re the kinect Im looking at, is here http://mumbai.olx.in/x-box-kinect-with-a-a​dventure-spotrs-cd-3-year-old-as-good-as-n​ew-and-hardly-used-3-times-iid-598091875
12:48 neue joined #openframeworks
13:00 neue joined #openframeworks
13:02 nylki_ joined #openframeworks
13:18 neue joined #openframeworks
13:40 dantheman joined #openframeworks
14:25 lmccart joined #openframeworks
14:25 burningdog joined #openframeworks
15:04 jacres joined #openframeworks
15:11 petersaints joined #openframeworks
15:28 neue joined #openframeworks
15:56 finger563 joined #openframeworks
16:01 LCID_Fire joined #openframeworks
16:18 ofarturo joined #openframeworks
16:24 neue joined #openframeworks
16:27 ncls "devices that have been plugged into an XBox"
16:27 ncls woahhh, that's a delayed answer
16:28 nicedice joined #openframeworks
16:31 pizthewiz joined #openframeworks
16:41 max3 joined #openframeworks
16:42 max3 hey i just compiled projectgenerator and i'm having this same error
16:42 max3 http://forum.openframeworks.cc/t/text-do​esnt-render-in-projectgenerator/11453/3
16:49 neue joined #openframeworks
16:56 dantheman joined #openframeworks
17:07 vade joined #openframeworks
17:14 max3 http://forum.openframeworks.cc/t/text-do​esnt-render-in-projectgenerator/11453/3
17:14 max3 hey i just compiled projectgenerator and i'm having this same error
17:17 dantheman oh weird
17:17 dantheman what OS?
17:18 Joel_re joined #openframeworks
17:19 Joel_re so basically, any kinect thats been plugged into an Xbox cannot be used with openframeworks?
17:28 dantheman IDK
17:29 dantheman theo has been working on it
17:29 dantheman so has dan wilcox
17:29 dantheman but neither of them are around
17:49 dantheman ofarturo: yo
17:49 dantheman question for you
17:49 dantheman if you're around
17:49 dantheman trying to figure out how I should handle 302's
17:49 dantheman inside the core with these updates I'm hacking on
17:49 max3 dantheman: can you help me with my problem?
17:49 dantheman maybe?
17:49 dantheman max3: what OS?
17:49 max3 http://forum.openframeworks.cc/t/text-do​esnt-render-in-projectgenerator/11453/3
17:50 max3 ubuntu 12.04
17:50 max3 that's not me but it's the same exact bug
17:50 dantheman did you install all the deps?
17:50 max3 yes
17:50 dantheman linux64?
17:50 max3 yes
17:50 dantheman from the release branch?
17:50 dantheman err release package or the git branch?
17:51 dantheman I always run off Master on Github
17:51 max3 release
17:51 dantheman on Linux it just works
17:51 max3 um
17:51 max3 master
17:51 max3 yes
17:51 max3 sorry have those 2 confused
17:51 dantheman yeah
17:51 dantheman they used to be the same thing
17:51 max3 i didn't pull because i don't need to setup a local repo but i downloaded the zip
17:51 dantheman but now they are different
17:51 dantheman ok I would suggest downloading the repo
17:51 dantheman and working off of that
17:51 dantheman but I saw this work
17:51 dantheman hmm
17:52 max3 i did
17:52 max3 that's what im saying
17:52 dantheman like I run OSX and Linux
17:52 max3 it's just that instead of doing a git pull
17:52 Joel_re_ joined #openframeworks
17:52 max3 i downloaded the zip
17:52 max3 from github web interface
17:52 dantheman oh oh oh ok
17:52 dantheman I thought you meant from here http://openframeworks.cc/download/
17:52 dantheman those are the official releases
17:52 max3 no
17:53 max3 well first i did that and then i went to check the git repo
17:55 max3 dantheman: so any ideas?
17:55 dantheman not really
17:55 dantheman um do a make clean?
17:55 max3 in projectmanager?
17:55 dantheman make sure your paths are correct and the folders are correct names
17:55 dantheman yeah
17:55 dantheman from the command line
17:56 dantheman just type make clean in the root of the project
17:56 dantheman so cd /apps/projectGenerator./
17:56 dantheman or update the projectGenerator
17:56 dantheman I'm at work so I can't really help too much
17:56 dantheman and don't have the issue in front of me
17:56 dantheman like I would have to boot up my linux image
17:56 max3 that's okay
17:56 max3 thanks anyway
17:57 dantheman sorry
17:57 dantheman watch that thread
17:58 Joel_re joined #openframeworks
18:11 nylki_ joined #openframeworks
18:22 Joel_re joined #openframeworks
18:35 pizthewiz joined #openframeworks
18:49 admsyn joined #openframeworks
18:55 jvcleave finger563 - exciting :)
19:04 ofarturo joined #openframeworks
19:14 kritzikratzi joined #openframeworks
19:33 finger563 yup! :)
19:33 finger563 and it really works now
19:33 finger563 now just gotta tie it in with transmission over wifi
19:34 finger563 :D
19:35 jvcleave finger563 - your code posted anywhere?
19:42 finger563 @jvcleave not yet, i'm cleaning it up tonight and i'll branch it off your repo if you want
19:43 finger563 it uses the hello_encode sample code to do the setup of the OMX and the buffers
19:43 finger563 and the YUV encoding still needs a tiny bit of work (everything has a green tint lol)
19:43 jvcleave cool - just curious :)
19:45 finger563 the other downside is i gotta figure out the right settings for OMX
19:45 finger563 cause the frames are written properly
19:45 finger563 but i havent figured out how to tell it what the timing is
19:45 finger563 so it plays them too quickly when you play back the file
19:46 jvcleave I may have actually just figured that out
19:46 finger563 yea? :)
19:47 finger563 the framerate the i tell it seems to have no effect, and the bitrate doesnt effect timing as far as i can tell
19:47 jvcleave the recordings from the camera were doing the same thing - I got the non-textured playback working again but was struggling with the textured renderer (in ofOMXPlayer)
19:48 finger563 yea i'm using your textured renderer
19:48 finger563 from your shaderApp code as a base
19:49 jvcleave if you want to try it search for
19:49 jvcleave nalStreamFormat.eNaluFormat = OMX_NaluFormatOneNaluPerBuffer
19:49 jvcleave and replace with
19:49 jvcleave nalStreamFormat.eNaluFormat = OMX_NaluFormatStartCodes
19:50 finger563 hmmm
19:50 finger563 interesting, i'll have to look into that :)
19:50 finger563 (once i get home from work, sadly)
19:51 jvcleave looping still doesn't work with the recorded files but I have a fix for that as well - I'm testing the above line with everything to make sure it doesn't cause other issues
19:53 finger563 what do you mean looping doesnt work? you can't replay them or what?
19:54 finger563 i've tried stitching many of my outputs together but again the timing makes everything too fast
19:56 jvcleave omxplayer doesn't do looping - ofxOMXPlayer can do looping but only with mp4 files (not h264 streams)
19:59 finger563 oh, i've only tried playing w/ vlc
20:03 jvcleave regarding framerate - everything I have gotten out of the encoder has been 25fps - no matter what I set it to - guessing it is hardcoded in (like the current camera being fixed at 30fps)
20:03 bitri joined #openframeworks
20:04 finger563 yea it may be hardcoded, that's about what i get too even though i feed it about half that
20:10 kritzikratzi joined #openframeworks
20:12 dantheman joined #openframeworks
20:30 fossterer joined #openframeworks
20:32 fossterer Hi! All of a sudden today I'm receiving this message for my app using OF on Android -- "Fatal Signal 11 (SIGSEGV) at 0x00000064"
20:35 fossterer Help please..
20:36 admsyn yeah that's pretty much the most generic error there is, unforunately
20:36 admsyn probably using a pointer that's not valid
20:36 admsyn when does it happen? Does it error on a particular line?
20:36 finger563 yea almost definitely bad ptr
20:37 fossterer No line number; The exact message is - "Fatal signal 11 (SIGSEGV) at 0x00000064 (code=1), thread 13857 (Thread-6796)"
20:38 fossterer with LogTag - "libc"
20:38 admsyn yeah still super generic
20:38 admsyn that kind of error (SIGSEGV) is a segmentation fault aka segfault
20:38 admsyn basically, using memory you're not supposed to
20:38 fossterer yeah! I see this is thrown when the issue is in native code..
20:38 admsyn yeah it doesn't really happen in Java I believe
20:39 fossterer But the same code ran with no errors all these days
20:40 fossterer Any ways to debug the issue?
20:41 admsyn right, because what's happening is that you're straying into "undefined" territory, which means basically anything can happen. In the past, you might have gotten away with it because of luck, but now you're not
20:41 admsyn If eclipse has a nice way of tracking memory leaks, that'd be a good place to start
20:41 admsyn another would be to take a look at how you're using pointers. if you are
20:42 admsyn when does the error happen?
20:44 lmccart joined #openframeworks
20:44 fossterer i.e. as soon as I start the activity; Except for the app's title nothing is displayed and after logging the above message the app smoothly quits
20:44 admsyn alright well that makes it pretty easy-ish then
20:45 admsyn comment out all of your setup() code, and see if that "fixes" it
20:45 fossterer (From LogCat) After "onSurfaceCreated" is invoked
20:45 fossterer really??
20:45 fossterer wait!
20:45 admsyn then introduce stuff line by line untill you find out what causes it
20:55 fossterer I commented everything inside setup().. The issue remained the same..
20:55 fossterer Also I commented everything inside update() too.. The issue remained the same..
20:56 admsyn alright so start working back up the chain then
20:56 admsyn your ofApp's member's constructors are going to fire before setup() so try commenting out those members
20:56 Joel_re joined #openframeworks
20:57 admsyn really though, this sounds more like it could just be a configuration thing
20:57 admsyn what might help narrow it down is if you comment out basically everything (all the ofApp's members) and then start bringing stuff back in
20:58 admsyn it's /really/ difficult to give better advice without more details about what exactly your app is doing
20:58 admsyn because basically all i've got to work with here is "it is broken. why?"
21:00 kureta joined #openframeworks
21:07 fossterer ofApp() directly has no constructors.. Do you want me to check "ofBaseApp's" ?
21:07 admsyn yeah I guess I should have explained that better
21:08 fossterer No.. I am just confirming it..
21:08 admsyn if your ofApp has objects (like ofVideoGrabber) the constructors for all of those will run before setup(), even if you didn't write your own ofApp constructor
21:08 admsyn and if one of those objects is doing something odd / bad, then that could be the cause of your segfault
21:09 admsyn because it would fire while your app is booting
21:09 admsyn anyway no, it's probably something else than ofBaseApp misbehaving
21:10 admsyn again, details. Can you post something like your ofApp.h file or some actual code?
21:11 fossterer please hold while i pastebin it...
21:11 admsyn sure
21:11 fossterer Here - http://pastebin.com/vbCAudsV
21:12 admsyn whats up with the commented out ofxAndroidApp?
21:12 admsyn did that line use to read public ofBaseApp, ofxAndroidApp ?
21:13 keeran joined #openframeworks
21:13 admsyn err *did that use to read public ofxAndroidApp ?
21:13 keeran hihi
21:13 admsyn hey keeran
21:13 keeran hey man, been a while :)
21:14 * keeran back on the ofx buzz
21:14 admsyn \o/
21:14 keeran having to suffer code::blocks and code that doesnt run on linux tho :(
21:14 admsyn ouch
21:15 keeran never thought id havemore luck running oss stuff on an apple OS over linux lol
21:15 lmccart joined #openframeworks
21:16 keeran looking for anyone who might have had a browser rendering in linux, or can suggest a widget to use for a scrolling list of clickable items :)
21:18 dantheman joined #openframeworks
21:18 admsyn as in a browser embedded in your ofApp's window?
21:18 keeran yea
21:19 admsyn I think that's what awesomium is all about
21:19 admsyn but it's $$ IIRC
21:19 fossterer "ofxAndroidApp" is what I got when I copied an existing example project. The project I'm working on was actually using "\ofBaseApp"
21:19 fossterer err "ofBaseApp
21:19 fossterer "
21:19 keeran yeah i cant get that compiling/running at all (either the ofxAwesomium lib is out of sync with the lib or im just plebbing up with codeblocks)
21:20 admsyn GLFW will give you scroll events though, if you're in the mood to hack your own
21:20 keeran might have to aye, thanks
21:20 admsyn fossterer: but your app is running on android, right?
21:21 fossterer mmm... I'm there.. None showed a difference earlier.. But again this error wasn't then..
21:23 admsyn yeah I'm not sure why it would have worked at all before, but I'm 99% sure you want to be deriving from ofxAndroidApp to make an android app
21:23 admsyn at the very least, that's by far the most obvious thing jumping out at me from your header
21:24 admsyn otherwise the raw PatternGenerator* might be something to examine, but if you're getting mysterious segfaults in your app's initialization phase, the fact that you're not deriving from ofxAndroidApp is pretty much screaming "wrong"
21:24 fossterer I changed it.. no change in the error message
21:27 admsyn yeah gonna need @ofarturo to weigh in then
21:27 admsyn ofarturo:
21:27 fossterer ofarturo:
21:27 admsyn otherwise a clean+build might be necessaru
21:28 fossterer a Clean, a Build Project, a Clean All, a Build All... Everything I'm doing it... Everytime
21:31 admsyn in the meantime it'll probably be helpful to break it down as much as possible to find the problem but
21:31 admsyn *problem bit
21:31 admsyn try making a new empty project, and bringing over stuff piece by piece until it breaks again
21:37 fossterer Also, the second time I run it,, It says -- "initGrabber(): camera already initialized" and "cannot start, thread already running"
21:39 admsyn if you're running it pretty quickly back-to-back, I'd guess your app claims control of the camera, then dies before releasing control, then you restart it again before the OS realizes nothing's actually using the camera
21:39 * admsyn is guessing, though
21:40 fossterer Probably... so the app claimed resources but died before doing anything, you say?
21:41 admsyn yeah I'm not too sure how Android deals with system resources, but for stuff that can only have one "owner" at a time, a misbehaving app (like one that segfaults instead of quitting cleanly) can confuse the OS for a little while
21:41 admsyn maybe
21:41 admsyn it depends
21:42 admsyn again, just guessing
21:43 Joel_re joined #openframeworks
21:44 pizthewiz joined #openframeworks
22:38 admsyn keeran: FYI https://github.com/openframew​orks/openFrameworks/pull/2786
22:40 keeran ah nice one ta
22:40 keeran have been looking at ofxhgui
22:41 pizthewiz joined #openframeworks
22:41 admsyn yeah depending on how your linux is it might be straightforwardish to just hook into whatever GLFW is wrapping
22:41 admsyn you shuold be able to get the raw window handle from GLFW via OF
22:41 admsyn like ofGetGTKWindowPtr() or something like that
22:41 admsyn I don't know if it's actually GTK
22:42 keeran :)
22:57 pizthewiz joined #openframeworks
23:05 pizthewiz joined #openframeworks
23:28 nylki joined #openframeworks

| Channels | #openframeworks index | Today | | Search | Google Search | Plain-Text | summary