Perl 6 - the future is here, just unevenly distributed

IRC log for #openframeworks, 2015-03-05

| Channels | #openframeworks index | Today | | Search | Google Search | Plain-Text | summary

All times shown according to UTC.

Time Nick Message
01:26 jvcleave joined #openframeworks
01:53 ar_tama joined #openframeworks
02:26 boltR joined #openframeworks
06:25 notjosh joined #openframeworks
08:20 notjosh joined #openframeworks
09:30 mhashmi joined #openframeworks
09:44 fuerstP joined #openframeworks
11:10 fuerstP joined #openframeworks
11:48 sebllll_ joined #openframeworks
14:47 HarryHaaren joined #openframeworks
15:09 ar_tama joined #openframeworks
15:18 wjf___ joined #openframeworks
15:49 jedahan joined #openframeworks
15:58 nok__ joined #openframeworks
15:59 reqshark joined #openframeworks
16:21 wjf___ joined #openframeworks
16:49 reqshark joined #openframeworks
17:45 GuidovanPossum joined #openframeworks
17:50 mhashmi joined #openframeworks
18:39 admsyn joined #openframeworks
19:36 krgn joined #openframeworks
19:36 krgn hi you all
19:36 admsyn hi krgn
19:36 krgn I fairly new at OF, and I have a small question regarding support for shaders
19:37 krgn I run linux (arch) and am trying to compile some of the example shaderss from git repo, but I get an error regarding support of my card.
19:38 krgn its a nvidia geforce 650 w/ nvidia drivers (gl 4.5)
19:38 krgn could it be that I'm doing something wrong during initialization of the window (ofSetCurrentRenderer(...))?
19:39 admsyn is the error saying you're running an old version of opengl?
19:39 krgn the error is: checkProgramLinkStatus(): OpenGL generated error 1282 trying to get the program link status, does your video card support shader
19:40 admsyn are you using OF 0.8.4, or are you using the master branch on github?
19:40 krgn accoring to https://developer.nvidia.com/opengl-driver it supports GLSL 4.5
19:40 krgn admsyn: master branch
19:40 krgn should I switch to stable?
19:40 admsyn no you should be fine, the trick is that you have to set the version of opengl you want to use in your main.cpp
19:41 admsyn by default I think you get opengl 2.something
19:41 krgn ah!
19:41 krgn ok, let me give that a try :)
19:41 krgn thanks!
19:41 admsyn no problem
19:42 admsyn things have changed a bit recently, though, I think the most up to date reference for what to do is in apps/devApps/explicitRendererExample
19:42 * krgn will have a look
19:43 admsyn the "settings" struct has fields for minor and major opengl version
19:43 notjosh joined #openframeworks
19:50 krgn ok, ofIsGLProgrammableRenderer retruns true now, but the shader still doesn't link
19:50 krgn maybe its the shader itself
19:50 krgn its the blur_frag.glsl I think
19:51 admsyn what's the #version?
19:51 krgn 120!
19:52 krgn thats wrong isn't it?
19:52 admsyn yeah that's a pretty old opengl version, so that may well be your problem?
19:52 krgn admsyn: cool, cheers, I'll dig around a bit
19:58 fuerstP joined #openframeworks
20:00 jedahan joined #openframeworks
20:06 GuidovanPossum I'm trying to run a program I'd written with 0.8.1 now with 0.8.4 and get this error now [ error ] ofOpenALSoundPlayer: sfReadFile(): couldn't read "/home/x/Downloads/of_v0.8.4_linux64_release/apps​/myApps2/LocalParticle/bin/data/sounds/rage.mp3" Floating point exception (core dumped)
20:08 GuidovanPossum I'd seen this similar post but mine doesn't even work in debug mode:   http://forum.openframeworks.cc/t/urgent-error-ofo​penalsoundplayer-sfreadfile-couldnt-read-asoundfi​le-wav-floating-point-exception-core-dumped/15408
20:15 wjf___ joined #openframeworks
20:15 admsyn is there any more to go on, GuidovanPossum?
20:16 admsyn it sounds like an error generated from openAL itself, might be more relevant to google openAL things than OF things there
20:16 admsyn maybe it's just a buffer getting deallocated early or something though
20:18 GuidovanPossum that's all I could figure out, this is where I assign it in ofApp::setup(): dog.loadSound("sounds/rage.mp3");
20:18 GuidovanPossum and if I comment that out the program works and doesn't crash on load
20:19 admsyn huh, if I had to guess it's an error converting the mp3 to wav
20:19 admsyn do you get similar results if you put a wav in there?
20:20 GuidovanPossum ok I'll look into it and try wav thanks
20:20 admsyn np
20:21 admsyn if that doesn't get you anywhere, maybe dig into the loadSound() implementation, I bet you at some point there's a more informative error that's getting thrown out
20:22 fuerstP joined #openframeworks
20:26 GuidovanPossum yeah that fixed it thanks! not sure why it would have worked before
20:27 admsyn switching to wav fixed it?
20:27 GuidovanPossum yes!
20:27 admsyn I'd have to guess something changed with mpg123 or whatever is the mp3 decoder on linux..
20:27 admsyn ¯\_(ツ)_/¯
20:29 GuidovanPossum I redid that pong sound effect demo app with some different samples and then have it controlling a particle field with the fft from the audio in the samples
20:44 krgn mm still getting 1282 (which apparently is GL_INVALID_OPERATION)
20:45 admsyn what are you getting the error on? Is it when you're loading the shader?
20:47 krgn admsyn: I commented out a call to linkProgram and now at least eh screen is black and thre is no error
20:48 krgn sorry for the noise, that was probably the problem (although I have no clue why :D)
20:48 admsyn ok, if there's an error when linking the program, though, you should get a better error in the console
20:48 admsyn usually something really specific, down to the line in the shader that's the proble,
20:49 krgn admsyn: ok yes, had those kinds of errors before as well
20:49 krgn cool, onwards...
23:13 jvcleave_ joined #openframeworks
23:28 Sembei joined #openframeworks
23:48 pizthewiz joined #openframeworks
23:57 pizthewiz Does only the ofQTKitGrabber support recording, no recording on Windows?

| Channels | #openframeworks index | Today | | Search | Google Search | Plain-Text | summary