Camelia, the Perl 6 bug

IRC log for #padre, 2010-05-22

| Channels | #padre index | Today | | Search | Google Search | Plain-Text | summary

All times shown according to UTC.

Time Nick Message
00:16 teejay joined #padre
00:44 Haarg joined #padre
00:45 Haarg joined #padre
00:50 Haarg joined #padre
01:08 Haarg joined #padre
01:47 Haarg joined #padre
02:53 psybermonkey joined #padre
03:00 psybermonkey_ joined #padre
03:33 waxhead joined #padre
03:41 BillN1VUX joined #padre
03:50 |Sno| joined #padre
03:58 [Sno] joined #padre
04:03 Haarg joined #padre
04:46 pece joined #padre
04:54 pece2 joined #padre
04:58 pece joined #padre
05:41 kyanardag joined #padre
06:33 Xaero joined #padre
06:41 Xaero anyone there to test something with padre?
06:51 waxhead Xaero, test what?
07:15 user_3878 joined #padre
07:20 user_3878 joined #padre
08:06 Xaero sorry had to go away for a while
08:06 Xaero when I open a .pl or .pm file in padre it crashes
08:07 Xaero happening for anyone else?
08:07 Xaero I just upgraded to padre 0.62
08:08 Xaero as soon as I open a file it shows a busy (time piece) in the status bar next to where it says scintilla then crashes
08:09 Xaero do you need the error report? It pops up a dialog to send/don't send error report to microsoft
08:16 waxhead Xaero, how do you open the file?
08:16 waxhead from the commandline?
08:16 Xaero open the file in padre
08:16 waxhead ie padre c:\temp\file.pm
08:16 Xaero no
08:16 Xaero drag and drop and file>open
08:16 waxhead I've opened plenty of files in padre since last night...
08:16 Xaero crap
08:16 waxhead ok..
08:17 Xaero then I'm doomed again
08:17 waxhead Xaero, so what's the error you get?
08:32 Xaero joined #padre
08:33 Xaero sorry i got disconnected, checking irclog just a sec
08:33 Xaero it pops up with a box to send error report to microsoft
08:48 danlucraft joined #padre
09:15 eilara joined #padre
09:18 Sewi joined #padre
10:42 Xaero_ joined #padre
10:55 Xaero joined #padre
10:55 danlucraft1 joined #padre
11:29 Xaero joined #padre
11:58 Xaero joined #padre
12:06 awnstudio joined #padre
12:09 waxhead Xaero, does it say what has crashed?
12:10 Xaero sorry totally forgot about pasting the link
12:10 Xaero http://lookpic.com/d2/i2/1285/caMadfpQ.png
12:10 Xaero i can't copy what's in the box, that error report is huge
12:11 Xaero does this make more sense: http://lookpic.com/d2/i2/3549/S0c60eJ.png
12:12 danlucraft joined #padre
12:13 Xaero know what, I just remembered that before I upgraded to 0.62 I had 0.61 and when I closed it one day it was still running in the background which I discovered after 2 days
12:13 Xaero maybe there was a problem before I upgaded itself
12:16 Xaero erm.. I can't type anything in it, it crashes
12:21 Xaero_ joined #padre
12:22 Xaero_ sorry i got disconnected, checking irclog just a sec
12:22 Xaero_ i think something to do with the parsing/hilighting
12:22 Xaero_ it stays open if I don't type anything, but after I type a few letters it crashes
12:50 Xaero joined #padre
13:01 Xaero joined #padre
13:47 pece joined #padre
13:55 pece joined #padre
15:00 Haarg joined #padre
15:32 Xaero joined #padre
16:00 danlucraft1 joined #padre
16:10 BillN1VUX joined #padre
16:17 kthakore left #padre
16:26 szabgab Xaero, that looks like a very deep C-level error not a Perl error
16:27 szabgab so it might come from perl or wxWidgets I guess
16:27 Xaero how come only I have the problem?
16:27 szabgab maybe other windows users compiled it differently
16:28 szabgab how have you installed perl and wxWidgets and wx ?
16:28 Xaero i have strawberry perl 5.12.0.1 and compiled with the mingw compiler that comes with strawberry perl
16:29 Xaero install Alien-Wxwidgets and Padre from cpan
16:29 szabgab so I am not sure if that is the source but I guess few have used 5.12 on windows so far
16:29 szabgab maybe there is some issue
16:30 szabgab Alias and CSJewel might be of help there
16:30 szabgab but neither of them are around now
16:30 szabgab and azawawi but I have not seen him for ages
16:30 Xaero it only happens if I type something in the editor, you still thing it could be wxwidgets?
16:30 BillN1VUX Alias should be headed for the airport about now
16:31 BillN1VUX was all of WX built with mingw ?
16:31 Xaero everything built with what came with strawberryperl 5.12.0.1 and cpan
16:32 szabgab Xaero, do you have the SVN checkout of Padre?
16:32 szabgab actually you don't even need that
16:32 szabgab Padre installs a script called 30_editor.pl
16:33 szabgab find it and try using that.
16:33 szabgab it is a very simple editor - about the level of padre 0.03 I think
16:33 szabgab without threads
16:33 szabgab and without most of the features
16:34 szabgab there are a few other simple wx scripts in the same directory that you can see if they are working well or crashing
16:35 Xaero which directory is it?
16:36 szabgab c:\strawberry\perl\
16:36 szabgab search there
16:45 Xaero it's in C:\strawberry\perl\site\lib\aut‚Äčo\share\dist\Padre\examples\wx, I ran all of them everything is fine
16:46 szabgab have you used the editor, typed in text ?
17:03 Xaero yeah
17:03 Xaero works fine, i clicled on the buttons and dragged the butterfly too, everything worked fine
17:11 szabgab so the problem might be in the threading thing of Padre or some more advanced feature of wx
17:17 Xaero i was thinking of reinstalling perl and all the modules into a seperate local::lib directory and then do a fresh install of wxwidgets and padre
17:18 Xaero since i didn't know much about perl modules and their management I ended up installing unwanted modules to test now I can't remove them
17:34 szabgab_ joined #padre
17:35 szabgab_ Xaero, I don't use local::lib on my Windows box but you can try that if you feel like it :-)
17:35 Xaero uninstallation and upgrading is difficult without it
17:50 szabgab oh, you cannot uninstall 5.10 and install 5.12 and expect it to work
17:51 szabgab they are not binary compatible
17:51 szabgab but of course within the major version that *should* work
18:26 Xaero but I did a clean install
18:26 Xaero I "uninstalled" activeperl, removed the directory, removed it from the path..
18:26 Xaero then installed strawberry and wx and padre
18:27 szabgab then we are toast :-(
18:27 szabgab and have all the tests passed ?
18:29 szabgab the only recommendation I can give is to complain to CSJewel and in the meantime install Strawberry 5.10 or the Padre stand-alone and upgrade using the cpan shell
18:31 Xaero all the test don't pass do it come up with something like"...uninstall = OK..." something like that at the end?
18:32 Xaero i see that at the end, no errors or test failed shows up
18:33 Xaero rephasing: if all the tests don't pass does it say something like"...uninstall = OK..." something like that at the end?
18:34 Xaero when I installed these modules it shows something like make uninstall = or --OK or something I don't remember
18:37 LeK joined #padre
19:00 szabgab then the tests seems to be ok
19:00 szabgab and of course they are if the thing got installed without the use of the force
19:01 Xaero i just did cpan> upgrade Padre and it went though without any issues
19:02 Xaero i'll just reinstall perl anyway, i need a good copy and a testing copy so that I can install and uninstall modules without worrries and still have a working clean perl installation
19:45 danlucraft joined #padre
20:09 BillN1VUX joined #padre
20:40 pece joined #padre
23:39 Hyppolit svn: r11496 | waxhead++ | http://padre.perlide.org/trac/changeset/11496
23:39 Hyppolit Version bump to 0.05
23:39 Hyppolit trunk/Padre-Plugin-SVN/lib/Padre/Plugin/ trunk/Padre-Plugin-SVN/lib/Padre/Plugin/SVN/Wx/

| Channels | #padre index | Today | | Search | Google Search | Plain-Text | summary