Camelia, the Perl 6 bug

IRC log for #padre, 2012-01-09

| Channels | #padre index | Today | | Search | Google Search | Plain-Text | summary

All times shown according to UTC.

Time Nick Message
00:04 Hyppolit svn: r17836 | adamk++ | http://padre.perlide.org/trac/changeset/17836
00:04 Hyppolit Adding a simple background task wrapper around Padre::Pod2HTML
00:04 Hyppolit trunk/Padre/lib/Padre/Task/
00:48 bowtie left #padre
01:07 Hyppolit svn: r17837 | adamk++ | http://padre.perlide.org/trac/changeset/17837
01:07 Hyppolit Adding wxFormBuilder POD viewer
01:07 Hyppolit trunk/Padre/lib/Padre/Wx/FBP/
01:18 Hyppolit svn: r17838 | adamk++ | http://padre.perlide.org/trac/changeset/17838
01:18 Hyppolit Improving the Wx constant loading to suppress duplicate error messages
01:18 Hyppolit trunk/Padre/lib/Padre/Wx/
01:23 ecocode joined #padre
02:00 Hyppolit svn: r17839 | adamk++ | http://padre.perlide.org/trac/changeset/17839
02:00 Hyppolit Added a file2html alternative which reads files directly
02:00 Hyppolit trunk/Padre/lib/Padre/
02:01 Hyppolit svn: r17840 | adamk++ | http://padre.perlide.org/trac/changeset/17840
02:01 Hyppolit Adding sample POD frame
02:01 Hyppolit trunk/Padre/
02:02 Hyppolit svn: r17841 | adamk++ | http://padre.perlide.org/trac/changeset/17841
02:02 Hyppolit The built in Padre::Wx::HtmlWindow load_file method now runs in the background
02:02 Hyppolit trunk/Padre/lib/Padre/Wx/ trunk/Padre/lib/Padre/Wx/FBP/ trunk/Padre/lib/Padre/Wx/Frame/
02:06 Hyppolit svn: r17842 | adamk++ | http://padre.perlide.org/trac/changeset/17842
02:06 Hyppolit Adding background_pod (although the task does not support it yet)
02:06 Hyppolit trunk/Padre/lib/Padre/Wx/
02:14 user_7738 joined #padre
02:34 sugar joined #padre
03:30 asarch joined #padre
04:07 [Sno] joined #padre
04:18 Hyppolit svn: r17843 | szabgab++ | http://padre.perlide.org/trac/changeset/17843
04:18 Hyppolit Update the messages.pot file
04:18 Hyppolit trunk/Padre/share/locale/
05:09 mishin joined #padre
05:34 sewi_work joined #padre
06:27 nornagest joined #padre
07:30 Di-ima joined #padre
08:00 Hyppolit svn: r17844 | adamk++ | http://padre.perlide.org/trac/changeset/17844
08:00 Hyppolit Updated to FBP::Perl 0.72
08:00 Hyppolit trunk/Padre-Plugin-FormBuilder/ trunk/Padre-Plugin-FormBuilder/lib/Padre/Plugin/ trunk/Padre-Plugin-FormBuilder​/lib/Padre/Plugin/FormBuilder/ trunk/Padre-Plugin-FormBuilder/t/data/
08:26 mj41 joined #padre
08:34 waxhead joined #padre
08:56 daxim joined #padre
09:39 sheepx joined #padre
09:49 mishin joined #padre
09:49 waxhead hey everyone...
09:49 mishin Hi
09:49 waxhead how goes the padre code cutting?
09:49 waxhead no alias... guess I won't be able to get an idea when we are looking to release next...
10:29 zenog joined #padre
10:29 zenog Hi #padre
10:29 zenog What does the "Favorite" panel in the CPAN explorer do?
10:29 zenog I'd like to know that so I can translate it to German.
10:30 zenog Also, why is it "favorite", not "favourite"? I thought Padre's English should be the New Britstralian variant, not American English ;-)
10:37 bowtie joined #padre
10:44 szabgab hi guys
10:44 bowtie szabgab, hi
10:48 bowtie szabgab, I have a request for you, can you submit a delete request for Debug::Client 0.11 please, so that there is just 0.12, 0.16 and 0.17_04 I have submitted delets for 0.13_10 and 0.17_02
10:48 bowtie thanks
10:49 waxhead hey zenog
10:49 waxhead hey szabgab
10:50 szabgab sure
10:53 szabgab bowtie: why shall I keep 0.12 ?
10:54 bowtie szabgab, debug-Client 0.12 is required for Padre 0.92 and below, due to changes in the api,
10:56 zenog hey waxhead szabgab bowtie
10:57 szabgab @,  maybe you saw that I have been quite active on variu social networks recently
10:57 szabgab I'd like to see if we could use either Facebook or Google+ to provide help to people using Padre
10:57 szabgab and to enlarge the circle of the Padre users
11:10 szabgab so who is with me for this?
11:12 bowtie szabgab, If you think this is the way to go, that's ok by me. I don't use social networks :)
11:13 szabgab what a phrasing "the way to go"
11:14 bowtie szabgab, ok marketing guru what should it be :)
11:15 szabgab I am a greeen marketing guru, if any :)
11:16 sugar joined #padre
11:16 daxim congratulations, and already you manage to be annoying!
11:17 daxim fwiw, I started ad filtering on "maven" last week ago
11:17 szabgab that's good
11:18 daxim yes, it means you are successful
11:20 szabgab there are people who can make a living just by their own pure awesomeness
11:20 szabgab I am not one of those
12:50 GabrielVieira joined #padre
13:20 dolmen joined #padre
14:02 daxim joined #padre
14:18 jnap joined #padre
14:21 sugar_ joined #padre
14:33 asarch joined #padre
15:10 c0bra joined #padre
15:12 run4flat joined #padre
15:13 c0bra Question: I've installed padre and it seems like @INC isn't working right. the perl executable works but it can't find any of the installed modules. I've tried logging off/on and rebooting, thinking maybe it was an environment variable issue.
15:13 c0bra Any ideas?
15:13 run4flat In what way is it not working?
15:13 run4flat are you trying to run your script directly from Padre?
15:14 c0bra "Can't locate (X) in @INC" when I do "perl -M(X)"
15:14 c0bra or when I try to use the dancer start-up script, for example
15:14 c0bra No this is straight on the command ine
15:14 run4flat What's your OS?
15:14 c0bra Windows 7
15:14 run4flat Windows?
15:15 run4flat Hmm...
15:15 c0bra Yea. Windows and strawberry perl
15:15 c0bra Padre appears to work fine
15:16 Mithaldu c0bra: download process monitor
15:16 Mithaldu then use it to check what the perl process is trying to access
15:17 run4flat c0bra: does @INC look reasonable? If you print out @INC, does it look like it points to your Strawberry install directory?
15:18 run4flat you can try this: perl -e "print join(qq{\n}, @INC)"
15:20 c0bra oh you know what
15:20 run4flat what?
15:20 Hyppolit what is that link you send me?
15:20 c0bra I think it's using a perl executable that came with git
15:21 run4flat I didn't send any links, just something you could copy-and-paste onto your command line. :-)
15:21 run4flat perl -e "print join(qq{\n}, @INC)"
15:21 run4flat Looks like it's referencing git?
15:21 c0bra No the paths are for a *nix environment
15:22 c0bra in @INC, apparently
15:22 run4flat oh
15:22 run4flat try the same thing, but directly working with Strawberr
15:22 c0bra yea
15:22 c0bra Looks like it works
15:23 run4flat c:\strawberry\...\perl.exe -e ...
15:23 c0bra I just need to get the environment to run the strawberry perl and not the git one
15:23 run4flat gut reaction says modify %PATH%, but I'm not so sure
15:23 run4flat that could mess up git
15:24 run4flat but, you could create a special console startup for Perl (or git) that sets the correct path for using that perl
15:24 c0bra yea
15:26 c0bra I just renamed the git perl.exe
15:26 c0bra works! thanks guys
15:26 run4flat glad to help. :-)
15:26 run4flat just be  sure that git still works when *it* tries to run perl
15:27 run4flat good luck
15:27 c0bra right
15:29 jnap joined #padre
15:30 jnap joined #padre
15:32 jnap_ joined #padre
15:39 nornagest_ joined #padre
15:39 Hyppolit svn: r17845 | adamk++ | http://padre.perlide.org/trac/changeset/17845
15:39 Hyppolit Padre::Wx::import now takes parameters for loading Wx subsystems and then loading the new constants for them at the same time.
15:39 Hyppolit trunk/Padre/lib/Padre/ trunk/Padre/lib/Padre/Wx/ trunk/Padre/lib/Padre/Wx/Dialog/ trunk/Padre/lib/Padre/Wx/FBP/
15:49 Hyppolit svn: r17846 | adamk++ | http://padre.perlide.org/trac/changeset/17846
15:49 Hyppolit Fix newlines
15:49 Hyppolit trunk/Padre/lib/Padre/Task/
15:52 bowtie adamk, what's happening to About FBP in Padre.fbp?
16:18 Hyppolit svn: r17847 | szabgab++ | http://padre.perlide.org/trac/changeset/17847
16:18 Hyppolit Update the messages.pot file
16:18 Hyppolit trunk/Padre/share/locale/
16:28 kaare__ joined #padre
16:41 dolmen joined #padre
16:50 jnap_ joined #padre
16:56 jfroebe joined #padre
16:56 zipf joined #padre
17:03 Hyppolit # 1377 :  Search dialog claims unsuccessful search even though it was successful (new defect) [ http://padre.perlide.org/trac/ticket/1377 ]
17:05 Hyppolit # 1377 :  Search dialog claims unsuccessful search even though it was successful (new defect) new attachment [ http://padre.perlide.org/trac/ticket/1377 ]
17:17 mj41 joined #padre
17:24 Hyppolit svn: r17848 | zenogantner++ | http://padre.perlide.org/trac/changeset/17848
17:24 Hyppolit update German translation
17:24 Hyppolit trunk/Padre/share/locale/
17:24 zipf joined #padre
17:26 kaare__ joined #padre
17:27 mj41 joined #padre
17:31 Hyppolit # 1377 :  Search dialog claims unsuccessful search even though it was successful (new defect) by bowtie  [ http://padre.perlide.org/t​rac/ticket/1377#comment:1 ]
17:32 zenog bowtie: Hm. Strange.
17:32 GabrielVieira joined #padre
17:33 bowtie just repeated with r17848, do you want a png in ticket?
17:33 Hyppolit Changeset #17848 http://padre.perlide.org/trac/changeset/17848
17:34 Hyppolit # 1377 :  Search dialog claims unsuccessful search even though it was successful (new defect) by bowtie  [ http://padre.perlide.org/t​rac/ticket/1377#comment:2 ]
17:35 bowtie zenog, due you remember #1352, have you checked about recently
17:35 Hyppolit # 1352 :  improvement suggestions for the new About box (assigned defect) by bowtie  [ http://padre.perlide.org/t​rac/ticket/1352#comment:6 ]
17:40 zenog bowtie: I do not need proof - I believe it works for you.
17:40 zenog Which platform do you run Padre on?
17:41 Hyppolit # 1377 :  Search dialog claims unsuccessful search even though it was successful (new defect) by bowtie  [ http://padre.perlide.org/t​rac/ticket/1377#comment:3 ]
17:41 bowtie as requested added to ticket
17:44 bowtie zenog, any thing else I can do?
17:45 zipf joined #padre
17:51 Mithaldu joined #padre
17:53 Hyppolit # 1377 :  Search dialog claims unsuccessful search even though it was successful (new defect) by zenogantner  [ http://padre.perlide.org/t​rac/ticket/1377#comment:4 ]
17:57 Maltus joined #padre
18:16 dodathome joined #padre
19:13 mj41 joined #padre
19:42 GabrielVieira joined #padre
22:28 GabrielVieira joined #padre
23:12 run4flat Hello all, I have an issue installing Wx. I can't see the channel listing from my client, so (1) is there a better channel where I can discuss this or (2) would y'all mind if I ask my question here?
23:13 bowtie run4flat, what os?
23:14 run4flat Ubuntu 10.10
23:14 run4flat I'm using local::lib because I don't have admin privileges
23:15 run4flat The perl I'm using is stock: 5.10.1
23:15 bowtie run4flat, ok, see http://padre.perlide.org/trac/wiki/DownloadUbuntu
23:15 bowtie have you looked at using perlbrew
23:16 run4flat I was using Perlbrew
23:16 run4flat then I had some confusion and thought my perlbrew went to crap
23:16 run4flat so I switched over to local::lib
23:16 run4flat (turns out I was logged into a Mac machine, but we are using a NFS, so I *thought* I was on my local machine. Binary incompatibilties. Joy)
23:17 bowtie next?
23:17 run4flat The problem is in the compilation step:
23:17 run4flat /usr/bin/perl /home/visitors/dcmertens/per​l5/lib/perl5/ExtUtils/xsubpp  -nolinenumbers -noprototypes  -typemap /usr/share/perl/5.10/ExtUtils/typemap -typemap typemap  Wx.xs > Wx.xsc && mv Wx.xsc Wx.c
23:17 run4flat Warning: Found a 'CODE' section which seems to be using 'RETVAL' but no 'OUTPUT' section. in XS/Locale.xs, line 76
23:17 run4flat g++   -c  -I. -I. -I/usr/lib/wx/include/gtk2-unicode-debug-2.6 -I/usr/include/wx-2.6  -D_REENTRANT -D_GNU_SOURCE -DDEBIAN -fno-strict-aliasing -pipe -fstack-protector -I/usr/local/include -D_LARGEFILE_SOURCE -D_FILE_OFFSET_BITS=64    -DVERSION=\"0.9903\" -DXS_VERSION=\"0.9903\" -fPIC "-I/usr/lib/perl/5.10/CORE"  -D__WXDEBUG__ -D__WXGTK__ -D_FILE_OFFSET_BITS=64 -D_LARGE_FILES -DNO_GCC_PRAGMA   Wx.c
23:17 run4flat Wx.c: In function ‘void XS_Wx__LogChain_DetachOldLog(PerlInterpreter*, CV*)’:
23:17 run4flat Wx.c:8025: error: ‘class wxLogChain’ has no member named ‘DetachOldLog’
23:18 run4flat oh, crap
23:18 bowtie did you do $sudo apt-get install libwxbase2.8-0 libwxgtk2.8-0 libwxbase2.8-dev libwxgtk2.8-dev
23:18 run4flat it looks like I don't have the dev libraries installed on this machine
23:18 run4flat can't
23:18 run4flat don't have admin privileges
23:19 run4flat but I can bug an admin
23:19 run4flat I compiled this on another machine in our network, on which I did get the dev files installed
23:19 run4flat OK, thanks
23:19 run4flat I'll get those installed and see if I can get it working
23:19 bowtie lucky admin's
23:21 bowtie run4flat, It would be good if you could provide feedback, so that we can update wiki page if needed :)
23:21 run4flat oh, sure
23:21 bowtie or you can register and add comments?
23:21 run4flat I may be registered...
23:21 run4flat from many moons ago
23:21 bowtie Hyppolit, trac!
23:21 Hyppolit Trac registration opened for 5 minutes. Please visit http://padre.perlide.org/trac/register to register
23:22 bowtie great how about now
23:22 run4flat ha, yeah, I still have my old credentials
23:22 run4flat The installation instructions are useful, but I expect they will also need to suggest forcing a re-installation of Alien::wxWidgets
23:22 run4flat I think
23:23 bowtie or pm-uninstall i think
23:24 run4flat that's not installed on my system
23:25 run4flat that's not a cpan command, is it?
23:26 run4flat ---
23:26 bowtie look at cpanm => http://search.cpan.org/dis​t/App-cpanminus/bin/cpanm
23:26 run4flat yeah, maybe some day I'll switch over. :-)
23:26 run4flat At any rate, the compilation is failing
23:26 run4flat same problem as before
23:26 Hyppolit Trac registration closed
23:26 bowtie and http://search.cpan.org/~xaicron/App-pm​uninstall-0.28/lib/App/pmuninstall.pm
23:27 run4flat OK, the problem looks like it's finding wx-2.6, not 2.8. I've struggled with this before
23:28 run4flat It happens when you try to install Wx (or Alien::wxWidgets, I believe) under 2.6, and *then* upgrade to 2.8
23:28 run4flat I thought it could be solved by forcing a reinstall of Alien::wxWidgets, but that didn't work
23:28 run4flat (sorry, just keeping you posted, I'm still working through it)
23:29 bowtie you need the ubuntu 2.8 files
23:29 run4flat yeah, I just had those installed
23:30 run4flat the problem arises when you install Alien::wxWidgets with the 2.6 files, and *then* install the 2.8 library files
23:30 bowtie use cpan and install App::pmuninstall
23:30 bowtie then you can easly unistall cpan modules
23:31 run4flat well, ok, but I figured installing over a module would be sufficient
23:33 bowtie better to reinstall due to Wx bump
23:46 Hyppolit wiki page http://padre.perlide.org/trac/wiki/DownloadUbuntu changed by run4flat
23:49 bowtie run4flat++
23:49 run4flat dammit, no that didn't work
23:49 run4flat grrr\
23:49 run4flat sorry
23:49 run4flat updated the wiki before testing
23:49 run4flat (forgot I hadn't checked it)
23:50 bowtie run4flat, try cpanm -v Alien::wxWidgets
23:51 bowtie -v verbose
23:52 run4flat No, Alien::wxWidgets is up-to-date, its just that *it* thinks that my latest wx is 2.6
23:52 run4flat even after the re-install
23:53 run4flat but, since you asked:
23:53 run4flat cpanm (App::cpanminus) 1.5007 on perl 5.010001 built for i686-linux-gnu-thread-multi
23:53 run4flat Work directory is /home/visitors/dcmertens/.c​panm/work/1326153184.17926
23:53 run4flat You have make /usr/bin/make
23:53 run4flat You have LWP 5.836
23:53 run4flat You have /bin/tar: tar (GNU tar) 1.23
23:53 run4flat Copyright (C) 2010 Free Software Foundation, Inc.
23:53 run4flat License GPLv3+: GNU GPL version 3 or later <http://gnu.org/licenses/gpl.html>.
23:53 run4flat This is free software: you are free to change and redistribute it.
23:53 run4flat There is NO WARRANTY, to the extent permitted by law.
23:53 run4flat Written by John Gilmore and Jay Fenlason.
23:53 run4flat You have /usr/bin/unzip
23:53 run4flat Searching Alien::wxWidgets on cpanmetadb ...
23:53 run4flat Checking if you have ExtUtils::MakeMaker 6.31 ... Yes (6.55_02)
23:53 run4flat Checking if you have ExtUtils::Install 1.46 ... Yes (1.54)
23:53 run4flat Alien::wxWidgets is up to date. (0.54)
23:54 run4flat and f'ing ubuntu doesn't install perldoc by default
23:54 bowtie use nopaste http://scsys.co.uk:8001
23:54 run4flat oh, yeah
23:54 run4flat sorry
23:55 run4flat it's been a while since I've been in irc. :-)
23:55 run4flat You know, I think this may not be an issue with Alien::wxWidgets
23:55 run4flat Padre has trouble with that later, but the issue right now is with Wx
23:56 run4flat And, oddly enough, the Wx module does not appear to depend on Alien::wxWidgets, at least in my inspection
23:56 run4flat p3rl.org/Wx
23:59 run4flat yeah, it looks like a bug in Wx's detection logic

| Channels | #padre index | Today | | Search | Google Search | Plain-Text | summary