Camelia, the Perl 6 bug

IRC log for #padre, 2013-01-28

| Channels | #padre index | Today | | Search | Google Search | Plain-Text | summary

All times shown according to UTC.

Time Nick Message
00:20 SvenDowideit joined #padre
01:33 GabrielVieira joined #padre
03:22 asarch joined #padre
05:55 sewi joined #padre
07:22 sugar joined #padre
08:20 Kharec joined #padre
08:34 dod joined #padre
08:41 dod joined #padre
08:43 dolmen joined #padre
09:40 Kharec joined #padre
10:49 SvenDowideit joined #padre
11:01 SvenDowideit joined #padre
11:52 sugar joined #padre
13:32 jq joined #padre
13:43 bowtie joined #padre
13:43 bowtie hi all
14:16 sugar joined #padre
14:45 jq- joined #padre
14:57 sugar joined #padre
15:16 kaare_ joined #padre
15:27 akoya joined #padre
15:29 akoya hi there
15:34 akoya just installed Padre using macports.
15:36 akoya I have generated around 230 new perl ports up to the padre and some of its plugins
15:36 akoya I am on Leopard and my macports installation is Universal 32 bit ppc i386
15:37 akoya The installation needs some manual intervention at the moment to get everything compiled and running
15:39 akoya But I now have 0.96 Padre installation that works. This is using this configuration
15:39 akoya Padre 0.96
15:39 akoya Core...
15:39 akoya osname darwin
15:39 akoya archname darwin-thread-multi-2level
15:39 akoya Perl 5.12.4
15:39 akoya Hilos de ejecución 3
15:39 akoya RAM (no se admite)
15:39 akoya Wx::Scintilla 0.39
15:39 akoya Other...
15:39 akoya PPI 1.215
15:39 akoya Debug::Client 0.20
15:39 akoya Config /Users/akoya/Library/Application Support/.padre
15:40 akoya I am trying to package it standalone Application bundle but I still have some problems with dependencies.
15:41 akoya I cant seem to use cava with my perl installation though...
15:43 akoya wxWidgets 2.9.4 Cocoa rocks in comparison to the Carbon vesion. Including webkit support!
15:44 asarch joined #padre
15:44 akoya And I have found some bugs and workarounds that I would like to share
15:44 akoya hi there
15:45 akoya On my installation the debugger did not work until I reinstalled XQuartz.
15:45 bowtie akoya, hi
15:45 akoya As the docs say the installation of XQuartz breaks w/ every security update
15:45 akoya hi
15:46 akoya so this may be the problem with the debugger found by some users with the 0.92 osx standalone
15:47 bowtie the OSX members you need to talk to are 'tome' from wild perl and 'stkowski'
15:48 akoya also on my installation I get a command line window menu item (AltZ) without the feature being enabled and maybe this fixes the issue:
15:48 akoya OK, thanks.
15:49 bowtie both contributed to http://padre.perlide.org/trac/wiki/DownloadMacOSX
15:49 akoya This is the patch for the above issue:
15:49 akoya --- ActionLibrary.pm2013-01-28 16:17:29.000000000 +0100
15:49 akoya +++ ActionLibrary-NEW.pm2013-01-28 16:19:30.000000000 +0100
15:49 akoya @@ -1372,15 +1372,17 @@
15:49 akoya },
15:49 akoya );
15:49 akoya
15:49 akoya -Padre::Wx::Action->new(
15:49 bowtie or you could just add some more info
15:49 akoya -name        => 'view.command',
15:49 akoya -label       => _T('Show &Command Line'),
15:49 akoya +if (Padre::Feature::COMMAND) {
15:49 akoya +Padre::Wx::Action->new(
15:49 akoya +name        => 'view.command',
15:49 akoya +label       => _T('Show &Command Line'),
15:49 akoya +comment     => _T('Show the command line window'),
15:49 akoya +menu_method => 'AppendCheckItem',
15:49 akoya +menu_event  => sub {
15:49 akoya +$_[0]->show_command( $_[0]->menu->view->{command}->IsChecked );
15:49 akoya +},
15:49 akoya +);
15:49 akoya +}
15:49 bowtie akoya, yuck
15:49 akoya
15:49 akoya Padre::Wx::Action->new(
15:49 akoya name        => 'view.cpan',
15:49 akoya what kind of info?
15:50 akoya What do I need to post a patch to the track system
15:50 bowtie you need to create a new ticket and add patch,
15:51 akoya the docs said that the first step was to get in contact here and that's what I am trying to do
15:51 bowtie akoya, please don't dump a patch here, as all your good work may get lost, hence a ticke with a patch attached
15:51 akoya ok
15:52 bowtie if you create the ticket I will make it for attention of above
15:57 akoya ok
16:03 akoya Ok I created  Ticket #1481
16:03 akoya Thank you bowtie!
16:19 newbie_padre joined #padre
16:20 newbie_padre hello everybody
16:21 newbie_padre my simple script hello world dont display on screen
16:22 newbie_padre i am on mac os x 10.7.5
16:22 newbie_padre do you have an idea ?
16:24 akoya hi newbie_padre you mean the output
16:24 akoya or the source?
16:28 newbie_padre the output
16:28 newbie_padre sorry
16:28 newbie_padre when i launch the script , nothing
16:28 newbie_padre no errors
16:28 newbie_padre but nothing
16:32 akoya newbie_padre check that you have enabled execute in separate window in the preferences in Language - Perl 5
16:33 akoya also open your X11.app or XQuartz to check that it is working. If it is not reinstall
16:35 akoya This solved the same problem for me. My Xquartz installation was broken and I had one xterm process hanging around for every trial that I made debugging. Seems that the installation of XQuartz breaks with apple updates
16:36 newbie_padre ok
16:36 newbie_padre thank you
16:36 akoya YW
16:42 dod joined #padre
16:48 bowtie akoya++
17:25 stkowski joined #padre
17:51 bowtie stkowski, hi
17:51 bowtie stkowski, I marked #1481 for you, sorry
17:54 stkowski No worries.
17:58 Kharec joined #padre
18:45 dod joined #padre
19:03 Di-ima joined #padre
19:33 asarch joined #padre
19:36 bowtie stkowski, thanks
20:13 sugar_ joined #padre
22:23 Kharec joined #padre
22:30 SvenDowideit joined #padre
23:12 akoya_ joined #padre
23:17 botbot Welcome akoya
23:23 akoya thanks botbot
23:36 akoya help

| Channels | #padre index | Today | | Search | Google Search | Plain-Text | summary