Camelia, the Perl 6 bug

IRC log for #padre, 2013-06-01

| Channels | #padre index | Today | | Search | Google Search | Plain-Text | summary

All times shown according to UTC.

Time Nick Message
02:03 asarch joined #padre
02:47 ajmrch joined #padre
03:58 kaare joined #padre
05:46 user_8261 joined #padre
05:47 user_8261 help
05:47 botbot Welcome user_8261
05:48 user_8261 Guys, sub {($v1,$v2,$v3)}->(localtime); means for what?
06:23 sewi joined #padre
06:36 dod joined #padre
06:58 dod joined #padre
07:25 dolmen1 joined #padre
08:44 sewi1 joined #padre
09:47 dod1 joined #padre
09:48 dod1 joined #padre
15:06 botbot Welcome sugar
16:49 przemek joined #padre
17:09 sewi joined #padre
17:31 asarch joined #padre
17:52 user_4126 joined #padre
17:52 botbot Welcome user_4126
17:53 user_4126 anyone home?
17:55 user_4126 http://padre.perlide.org/trac/ticket/1494
17:56 user_4126 have some updates on this, can't find where to register on the trac website.
17:57 user_4126 fyi, these same issues are cropping up attempting to compile padre with cpan using fink's perl5.10 running PPC mac.
18:00 bowtie user_4126,  hi
18:02 bowtie user_4126, try with https://metacpan.org/release/​BOWTIE/Debug-Client-0.25_10/
18:02 tony_the_tiger joined #padre
18:02 tony_the_tiger hi
18:03 tony_the_tiger I just installed Padre on Linux 15 and it loads but clicking run script does nothing when I have a script loaded into Padre
18:03 bowtie user_4126, past the output of cpan install here please with http://paste.scsys.co.uk/padre
18:03 user_4126 Debug::Client version is 0.25, padre version .98 ..
18:03 tony_the_tiger Linux Mint 15
18:03 user_4126 ok.
18:03 bowtie user_4126, try again LOOK 0.25_10
18:03 user_4126 yes, thanks
18:04 user_4126 got it!
18:04 tony_the_tiger Do I need to configure something to get the run feature to work?
18:04 bowtie tony_the_tiger, hi
18:04 tony_the_tiger hi
18:05 bowtie tony_the_tiger, try toggling Tools -> Prefs -> perl 5 ( use external ) with a simple perl file
18:05 user_4126 just tried to startup, the installer placed root-owned file/folders in $HOME , it failed trying to copy the module in..
18:05 tony_the_tiger ok one second
18:06 bowtie tony_the_tiger, view this -> http://padre.perlide.org/trac/ticket/1474
18:07 bowtie user_4126, are you using cpan
18:07 tony_the_tiger ok
18:09 user_4126 hey bowtie, this might be a dumb question, but what do you recommend the best way to actually get that updated module into the delicate balance of perl environments?
18:10 tony_the_tiger I turned off use external and it works fine now
18:10 tony_the_tiger thank you
18:10 user_4126 ie, quickly can we add the repository, or should download and move in place somewhere?
18:11 bowtie user_4126, are you using a system perl or local perl
18:13 user_4126 you could call it a 'local' perl. had tried first with perlbrew, then when installing dependencies with fink, that got all messed up.. got rid of perlbrew and system perl in paths.. should only be using /sw (fink) version.. everything seems to be working OK.. compiling stuff for hours with OKs., etc
18:14 bowtie user_4126, ok, I have not used (fink)
18:15 user_4126 lets call it a local perl.
18:15 bowtie user_4126, do you use cpan or cpanm
18:15 user_4126 cpan
18:15 user_4126 will use anything that works though
18:15 user_4126 :)
18:15 user_4126 basically, cpan, and all the perl modules are self contained, and in the same environment as the binary libraries
18:15 bowtie cpan BOWTIE/Debug-Client-0.25_10.tar.gz
18:16 user_4126 k.
18:18 user_4126 ERROR: perl: Version 5.010000 is installed, but we need version >= 5.010001 at inc/Module/Install/Makefile.pm line 208.
18:18 bowtie user_4126, lol
18:18 user_4126 Warning: No success on command[/sw/bin/perl5.10.0 Makefile.PL]
18:18 user_4126 so.
18:18 user_4126 a typo?
18:19 bowtie user_4126, so you know what to do, install a more current perl
18:19 user_4126 its 5.10 not 5.01
18:19 user_4126 ?
18:19 bowtie user_4126, I use perlbrew it's great :)
18:19 asarch joined #padre
18:20 user_4126 the error says version 5.01 .. hows it coming up with that?
18:20 user_4126 since I know we're running an updated 5.10
18:20 bowtie user_4126, you have perl 5.010000 (v5.10) install you need perl 5.010001 (v5.10.1)
18:20 user_4126 great then..
18:21 user_4126 ok
18:21 user_4126 :)
18:22 user_4126 the best part about compiling software is that the goose chase never ends!!
18:22 bowtie user_4126, http://www.cpan.org/src/README.html
18:23 user_4126 thanks for the rtfm, its been a while.
18:23 user_4126 ;)
18:23 bowtie user_4126, suggest perl v5.16.3
18:23 user_4126 yes..
18:24 user_4126 I had 5.18 in there , but then fink installed 5.10 for some dependencies..
18:24 user_4126 then it was game over, half of it was bootstrapping different versions.
18:24 bowtie user_4126, ps ticket 1494 is all about term-readline
18:25 bowtie user_4126, you mixed a local perl with system never a good out come
18:25 user_4126 OK..
18:25 user_4126 right. so I thought, lets just use what fink brings..
18:26 bowtie user_4126, the general view is leave system alone, and do dev from local with perlbrew, ps use threads
18:26 user_4126 it could have been the cpan layout also..
18:26 user_4126 that was why installed perlbrew to begin with.
18:27 user_4126 to get the threaded version and not mess with system perl.
18:27 bowtie user_4126, yes as su you would be adding to system, and as local to perlbrew
18:27 bowtie user_4126, it's a bit like a wife and a mistress, never the two shell meet :)
18:27 user_4126 lol..
18:28 user_4126 only been compiling this for a solid week, whats another week or two?
18:28 bowtie perlbrew install perl-5.18.0 -Dusethreads
18:28 bowtie or
18:28 user_4126 yes yes!
18:28 bowtie perlbrew install perl-5.16.3 -Dusethreads
18:29 user_4126 but the problem is if the system libraries in /sw still look for non-perlbrew perl.
18:29 user_4126 can we ask perlbrew to recognize/manage another installation?
18:29 user_4126 thats all conjecture..
18:30 bowtie user_4126, no, you need to do some rtfm and ask your fellow fink users about using perlbrew
18:30 user_4126 I'm going to try 5.18 or whatever with perlbrew and see what happens..
18:31 user_4126 of course.. thanks for the input.
18:31 bowtie user_4126, Padre 0.98 needs perl 5.16.3, it will complain about 5.18.0
18:31 user_4126 bingo..
18:31 user_4126 the whole point is padre, so will install the 5.16.3
18:32 bowtie if you want to use 5.18.0 you will need to use the dev trunk of Padre :)
18:32 user_4126 I tried to download the binary and apparently its intel only
18:33 user_4126 so thanks. I've got some work to do, and will let y'all know how it works out.
18:33 user_4126 been in the rabbit hole for a while with this, making progress.
18:34 bowtie user_4126, can you use a nick name here so we know who we are talking to please
18:34 bowtie is fink the open OSX thingie
18:34 user_4126 will do next time.. thanks so much for the help
18:35 user_4126 yes
18:35 bowtie cool
18:36 bowtie user_4126, try stkowski when he is around he did this http://padre.perlide.org/trac/wiki/DownloadMacOSX
18:36 bowtie well updated it last any way :)
18:37 bowtie and all the citrus stuff
18:37 user_4126 yes, I saw that page already..
18:37 user_4126 thankyou
18:38 bowtie user_4126, tip install this perl module Term::ReadLine::Gnu Debug::Client likes it :)
18:38 bowtie esp OSX
18:38 user_4126 the binary I got from there said "wrong architecture" when trying to launch.. maybe there is another one hiding somewhere that supports the last PPC software
18:39 user_4126 (working on a dual-G5 tower antique here)
18:39 bowtie lol
18:39 bowtie I am on single core 686 here
18:45 user_4126 so, fink shows this version of perl : 5.10.0-7
18:45 bowtie user_4126, use perl -v
18:46 bowtie or perl -V
18:46 user_4126 wonder if we can tell cpan to update perl to a specific version? I just told it to update and I think its going for 5.18
18:46 bowtie cpan only updates modules, not core perl
18:49 user_4126 cool. so its perlbrew..
18:49 bowtie nods
18:50 user_4126 fyi, at first outset, trying to install padre, it complained that it needed perl v5.10 .. so when fink plunked down 5.10, I thought it would be good to go..
18:50 user_4126 now we know its 5.10.1, and not really, but better 5.16.3
19:01 ajmrch joined #padre
19:38 dualG5 joined #padre
19:39 dualG5 note to pkg maintainers. if the dependency graph dictates a lower limit on the perl version, is there a way to check before even getting started?
19:40 dualG5 initially 'cpan install Padre' failed on the stock MacOS 10.58 perl 5500 .. said requires at least
19:40 dualG5 perl 5.10..
19:40 dualG5 it may have stated the exact version number.. lets check!
19:42 dualG5 also, to manage the system perls, perlbrew, fink and the ui libraries installed in the fink environment, perlbrew needs write permission into the /sw/etc directory.
20:03 dualG5 joined #padre
20:06 dualG5 padre-brew-master is the right approach here.. it seems to have packaged all the specific details, at least for the OSX platform (* what was that compile flag again?*)
20:09 dualG5 well.. it assumes the wrong architecture..
20:42 dualG5 ... made some changes to padre-brew.pl checkout from github. testing it soon. FYI, its wanting to install perl 5.12 and not 5.13, is there any specific reason to use 5.12?
20:48 perlite_ joined #padre
20:49 dolmen1 joined #padre
20:52 botbot Welcome perlite
20:57 bowtie dualG5, 5.12 is good
21:24 dualG5 hey, so I added stanzas to padre-brew to make it recognize the machine architecture.
21:24 dualG5 it seemed to recognize and take up those compiler options, which for now are minimal and probably need to be researched/tested..
21:25 dualG5 can paste the updated code somewhere or send it up to github..
21:28 bowtie dualG5, you might find the links at end of this page help -> http://padre.perlide.org/t​rac/wiki/DownloadPerlbrew
21:29 bowtie dualG5, do you sue github?
21:29 bowtie s/sue/use/
21:32 dualG5 currently don't have account..
21:33 bowtie dualG5, ok, then do -> http://paste.scsys.co.uk/padre it's in the channel topic for next time
21:38 shadowpaste "dualG5" at 217.168.150.38 pasted "updated padre-brew.pl ; adds "osxlionppc";" (454 lines) at http://paste.scsys.co.uk/252549
21:39 shadowpaste "dualG5" at 217.168.150.38 pasted "updated padre-brew.pl ; adds "osxlionppc";" (454 lines) at http://paste.scsys.co.uk/252550
21:39 shadowpaste "dualG5" at 217.168.150.38 pasted "updated padre-brew.pl ; adds "osxleopardppc";" (454 lines) at http://paste.scsys.co.uk/252551
21:40 dualG5 pls strike the "osxlionppc" there's no such thing.!
21:40 dualG5 ;)
21:40 dualG5 (code is the same, just the title is different)
21:50 ServerSa_ joined #padre
21:58 ServerSage joined #padre
22:11 dualG5 joined #padre
22:17 bowtie the above 252551 is now in http://padre.perlide.org/trac/ticket/1505 for all
22:41 dolmen1 joined #padre
22:53 Di-ima joined #padre
22:58 ServerSa_ joined #padre
23:03 ServerSage joined #padre
23:07 ServerSa_ joined #padre
23:11 ServerSage joined #padre
23:16 ServerSa_ joined #padre
23:22 ServerSage joined #padre
23:24 ServerSa_ joined #padre
23:31 ServerSage joined #padre
23:34 ServerSa_ joined #padre
23:38 ServerSage joined #padre
23:50 ServerSa_ joined #padre
23:55 ServerSage joined #padre

| Channels | #padre index | Today | | Search | Google Search | Plain-Text | summary