Camelia, the Perl 6 bug

IRC log for #padre, 2013-09-19

| Channels | #padre index | Today | | Search | Google Search | Plain-Text | summary

All times shown according to UTC.

Time Nick Message
03:48 sewi joined #padre
05:41 dod joined #padre
05:47 dod joined #padre
07:07 dod joined #padre
07:58 Di-ima joined #padre
07:59 dod joined #padre
07:59 perlite joined #padre
07:59 botbot joined #padre
07:59 El_Che joined #padre
07:59 eliasp joined #padre
07:59 bowtie joined #padre
07:59 Lorn joined #padre
07:59 bricas joined #padre
07:59 patspam joined #padre
07:59 zamolxes joined #padre
07:59 garu joined #padre
07:59 BooK joined #padre
07:59 shadowpaste joined #padre
07:59 tokuhirom joined #padre
08:41 Plecto joined #padre
08:42 Plecto bowtie: hi
08:44 Plecto dod: hi
08:50 bowtie_ joined #padre
09:15 Plecto bowtie: is there a way to solve the issue with keyboard shortcuts? CDM+c, CMD+v, CMD+x does not work :(
09:27 bowtie_ Plecto: I am not in to keyboard short cuts, so I don't know, I just worked out that for the gui debug wrapper to show stdout as we progress through a file you need to set autoflush ok
09:27 sugar joined #padre
09:34 Plecto bowtie: is there a way to install a particular release of Padre?
09:34 Plecto I would like to try going back to version 0.96
09:34 Plecto which (apart from the blurry text issue on Mac retina display) was working fine for me
09:46 bowtie_ Plecto: yes, but you can not bang your drum about items that don't work when they do in Padre trunk ok
09:47 bowtie_ use cpanm followed by the download link from metacpan like so
09:47 bowtie_ cpanm http://cpan.metacpan.org/authors/​id/P/PL/PLAVEN/Padre-0.96.tar.gz
09:49 Plecto bowtie_: yes, I understand and share your point, but some features where working for me on 0.96 (such as keyboard shortcuts) and seems not working in dev version of PAdre
09:55 Plecto bowtie_: did we solve the t/15_locale.t ..............  issue?
09:56 Plecto bowtie_: version .96 does fails to install for the same issue :(
09:57 bowtie_ Plecto: to investigate t/15_locale.t we will only use Padre 0.99 trunk ok, all dev work is against current trunk
09:57 Plecto bowtie_: ok
09:58 Plecto bowtie_: so, I'm ready
09:59 Plecto bowtie_: I have 0.99 trunk installed and working
09:59 Plecto bowtie_: (apart from keyboard shortcuts)
09:59 bowtie_ Plecto: in Padre, can you load t/15_locale.t and Run-This-Test
09:59 bowtie_ Plecto: you will find that on menu under Run
10:02 bowtie_ Plecto: now send output to a terminal and comment out # use Test::NoWarnings; re-run-this-test and paste please
10:30 Plecto bowtie_: should I fisrt enable send output to external window and then do RUN-THIS-TEST?
10:31 bowtie_ Plecto: yes, otherwise you will have to run tests from a terminal to be able to copy output to paste
10:32 Plecto bowtie_: if I send output to a terminal I see no output
10:32 Plecto I see the output only if I send it to the output pane
10:33 bowtie_ Plecto: hold on
10:36 Plecto bowtie: but it seems I can copy and send you the output
10:36 Plecto shown in the output pane
10:37 bowtie_ Plecto: take a look at: Padre/Wx/Main.pm sub->run_command and check you have the same terminal set up locally or consider a patch :)
10:37 bowtie_ Plecto: ok, use output-panel then
10:38 bowtie_ Plecto: by commenting out Test::NoWarnings we should see the error hopefully
10:39 shadowpaste "Plecto" at 217.168.150.38 pasted "Problems with 15_locale.t" (14 lines) at http://paste.scsys.co.uk/269435
10:39 Plecto bowtie_: this is what I got without commenting out use Test::NoWarnings
10:40 bowtie_ Plecto: test-nowarnings is hiding the errors so we need to disable it to see an error ok
10:44 Plecto bowtie_: it seems that the output I get in the output pane does not change if I comment out Test::NoWarnings
10:44 Plecto :(
10:48 Plecto bowtie_: I looked into Padre/Wx/Main.pm sub->run_command  but could not understand if my terminal is the same
10:49 Plecto however, a terminal opens when I run a script
10:49 Plecto but no output shows in it
10:49 bowtie_ Plecto: ok, so it's now up to you to see if you can determine what the issue is with t/15_locale.t, hack have fun, you can always do an svn up
10:50 Plecto bowtie_: I read also this in the terminal where I run perl dev: 12:42:46: Debug: wxMacLaunch Bad bundle: /usr/local/ActivePerl-5.16/bin/prove
10:50 bowtie_ Plecto: as for terminal it was just a pointer so you can see what is happing
10:51 bowtie_ Plecto: I am unaware of wxMacLaunch Bad bundle
10:53 Plecto ok
10:57 Plecto bowtie_: do the info I sent you help in understanding the problem with locale?
10:57 Plecto bowtie_: also, how about the two issues with Copy/Paste shortcuts and output in external window? :(
10:57 Plecto bowtie_: I also noticed that running the test causes perl-dynamic to close unaxpectately
11:04 bowtie_ Plecto: I can not copy from output-pannel hence use external
11:05 bowtie_ Plecto: as for local, just add it in you code when you debug in padre and then comment out
11:06 Plecto bowtie_: ok for the local
11:09 Plecto bowtie_: as for the external window, as I said, it opens, but no output appears in it
11:09 Plecto bowtie_: can you give me some more hints on how to check the last issue?
11:09 Plecto this also was working for me with padre 0.96
11:14 bowtie_ Plecto: sorry I don't recall 0.96 it's over 18 months ago
11:21 Plecto bowtie_: ok,  can you give me some more hints on how to check the problem with output in an external window?
11:23 bowtie_ Plecto: I did, run_command
11:29 bowtie_ Plecto: use trac brouse source, try this -> bhttp://padre.perlide.org/trac/changeset​/19121/trunk/Padre/lib/Padre/Wx/Main.pm
11:37 Plecto I found the portion of the code in Main.pm where it references the terminal
11:37 Plecto but didn't find info on how to check if my terminal is compliant
11:37 Plecto with what is there required
11:38 bowtie_ Plecto: and the terminal types listed there are
11:45 Plecto bowtie_: uhmm, do Padre needs xterm?
11:45 Plecto I have it installed, but it is not the terminal that opens when output is set to go to external window
12:17 Plecto bowtie_: actually, xterm seems to be the terminal that was opened by version 0.96 of Padre on my machine
12:21 Plecto bowtie_: running this command in the shell xterm -sb -e "$cmd; sleep 1000" & (which I found in the Main.pm) actually opens xterm on my machine
12:36 bowtie_ Plecto: and the other option
12:40 Plecto bowtie_: sorry, what do you mean?
12:41 bowtie_ Plecto: system qq($ENV{COLORTERM} -e "bash -c \\\"$cmd; exec bash\\\"" & );
12:42 bowtie_ Plecto: so look at what $ENV{COLORTERM} is set to or you want it to be set to
12:50 Plecto joined #padre
12:50 Plecto bowtie_: I'm unble to run that command
12:51 bowtie_ Plecto: what is the value of $ENV{COLORTERM} on your machine
12:52 bowtie_ Plecto: sorry, wrong line, try this one: system qq(osascript -e 'tell app "Terminal"\n\tdo script "cd $pwd; clear; $cmd;"\nend tell'\n);
12:53 bowtie_ Plecto: what is an osascript in OSX
12:55 Plecto bowtie_: which package should I include to run it?
12:58 Plecto sorry, still unable to run
12:58 Plecto even from terminal
13:31 Plecto joined #padre
13:32 Plecto bowtie_: very strangely, CMD+c and CMD+v (keyboard shortcuts) works during debug!!!
13:32 Plecto bowtie_: how is that possible?
13:51 asarch joined #padre
14:17 bowtie_ Plecto: I did say look at Debug menu, try now
15:14 lostinfog joined #padre
16:07 kaare joined #padre
16:45 dod joined #padre
16:52 stkowski joined #padre
16:52 bowtie_ stkowski: hi
16:54 stkowski Heya bowtie
16:56 bowtie_ stkowski: any issues with sending stdout to either output-panel or external
16:57 bowtie_ stkowski: also hows the DIY coming on :)
16:58 stkowski Hang on a bit.. buried at work for the moment.
16:58 stkowski Things are coming along slowlt thought :)
16:58 stkowski er..though
16:59 bowtie_ stkowski: ok, just dump a reply here and I will read the backlog for it, all is cool :)
18:22 sewi joined #padre
20:00 lostinfog left #padre
20:33 sugar joined #padre
20:53 stkowski joined #padre
22:55 Plecto joined #padre
22:56 Plecto hello bowtie_
22:56 Plecto and hello all
22:57 Plecto stkowski: hi
22:57 Plecto stkowski: do you use Padre on Mac OSX?
22:58 stkowski Yes.
22:58 Plecto great!
22:58 Plecto which version are you running now?
23:00 Plecto stkowski: which version of Padre are you running on Mac OSX?
23:03 Plecto stkowski: u there?
23:03 stkowski Hang on. Dealing with work issues. Let me check
23:03 Plecto :)
23:14 Plecto stkowski: to busy right?
23:14 Plecto :(
23:23 Plecto stkowski: stkowski: I meant "too"
23:29 stkowski Yeah, Work is being a pain. Am waiting for Xcode 4.3 to finish it's update too
23:30 stkowski You just want confirmation of a given version?
23:30 Plecto yes
23:30 Plecto I'm on trunk version (0.99)
23:30 Plecto and I'm having several issues with it
23:30 Plecto :(
23:31 Plecto I need a working version of Padre back!!!!!
23:31 stkowski I"m on trunk as well. What issues?
23:31 Plecto I had version 0.96 which was working fine
23:31 stkowski Oh..I know I'm 0.99…don't know which specific build at the moment
23:31 Plecto but then decided to try trunk version to see if the retina display issue was solved
23:31 Plecto ok
23:32 stkowski I have two copies of Padre installed. One is the older binary. And the other is using trunk in dev mode out of the source tree.
23:32 Plecto Issue #1) Copy paste keyboard shortcuts do not work
23:33 Plecto I see
23:33 stkowski Ok. Once this update is done I can confirm the head version does or does not do that
23:33 stkowski But as for the last 0.99 I used, copy and paste worked fine
23:33 Plecto I have looked at: Tools->Prefs->Key-bindings and checked them
23:33 Plecto but with no success
23:33 stkowski Both on darwin ports perl, and citris perl
23:34 Plecto for me they work fine when debug is on!
23:34 Plecto I'm on activeperl
23:34 Plecto do you think that could be the issue?
23:35 stkowski Not sure actually.
23:36 stkowski It looks like the new version of Xcode is borking things for me. Fun
23:37 Plecto I have Xcode 4.6.3
23:37 stkowski I just updated to 5.0 today
23:38 Plecto Issue #2) output in external window is not shown! a terminal window opens, but no output is shown in it, while I see the output in the output pane if I disable the external window output
23:39 Plecto I see
23:42 stkowski ok…I am using 0.99 with wx 2.9.3 subversion r19788
23:42 botbot Changeset #19788 http://padre.perlide.org/trac/changeset/19788
23:42 stkowski And copy and paste works.
23:42 Plecto same version
23:43 stkowski Perl 5.14.2
23:43 Plecto same subversion
23:43 stkowski Let me double-confirm the right type of perl
23:43 Plecto Activeperl 5.16
23:43 stkowski I'm using Citris
23:44 stkowski The only other difference would be your prefs, file, of course.
23:44 Plecto uhm
23:44 stkowski If you run the dev mode does copy and paste work for you?
23:44 Plecto can we compare this?
23:44 Plecto I'm running only in dev mode
23:44 stkowski ok
23:44 Plecto I mean using the command "perl dev"
23:44 Plecto right?
23:44 stkowski I think you can move you're prefs file aside and let it build a new one
23:44 stkowski Yup
23:45 Plecto where is it located?
23:45 stkowski I use an applescript to launch that for my "dev" version of Padre
23:45 Plecto not familiar with applescripts :(
23:46 stkowski If I remember correctly
23:46 stkowski Inside the Padre directory, where you call the "dev" script
23:46 stkowski It makes a ".padre" directory
23:46 stkowski Move that aside and relaunch to start with fresh preferences, IIRC
23:46 Plecto ok
23:47 Plecto will try that right away
23:49 Plecto so, I delete the .padre directory right?
23:49 Plecto you mentined a pref file
23:50 Plecto issue#3) it does not remember the files (perl scripts) I was working on when I reopen Padre!
23:51 stkowski Don't delete. Move it aside. Put it back if it doesn't fx it, to save your prefs.
23:52 stkowski #3 sounds like a prefs error
23:55 Plecto ok
23:59 Plecto do you know how to tell cpan to follow dependencies?

| Channels | #padre index | Today | | Search | Google Search | Plain-Text | summary