Perl 6 - the future is here, just unevenly distributed

IRC log for #pdl, 2016-11-26

| Channels | #pdl index | Today | | Search | Google Search | Plain-Text | summary

All times shown according to UTC.

Time Nick Message
05:45 chm joined #pdl
09:04 opkick [pdl] amba commented on issue #201: Perl -V output: http://pastebin.ca/3742397... https://git.io/v1TP9
11:39 ilbot2 joined #pdl
11:39 Topic for #pdl is now Install PDL: http://pdl.perl.org/?page=install  | Book: http://pdl.perl.org/content/pdl-book-toc.html | Mailing list: http://pdl.perl.org/?page=mailing-lists | Pasting: http://scsys.co.uk:8001/pdl | Channel is logged by ilbot2: http://irclog.perlgeek.de/pdl/today | PRs: https://github.com/PDLPorters/pdl/pulls
13:23 opkick [pdl] devel-chm commented on issue #201: I think the problem may be version skew or something between the core xsubpp install and the one from ExtUtils::ParseXS.  I'm puzzled that you have a developers release of ExtUtils::MakeMaker 6.57_05 while the checks during the build seem to indicate 6.58 is present.  Does the problem persist if you use a higher version of ExtUtils::MakeMaker?  Maybe we need to bump the required version for PDL to avoid bitrot. 0
13:38 opkick [pdl] amba commented on issue #201: No, even with the most recent version of ExtUtils::MakeMaker installed, the 'cpanm PDL' command still fails.... https://git.io/v1T58
14:34 opkick [pdl] mohawk2 commented on issue #201: `ExtUtils::ParseXS` needs to be specified, at the right version, as a build (not configure) requirement. It is so specified, at line 459 of my local copy of PDL. Is an up-to-date version of `cpanm` running on that perl? https://git.io/v1TdH
14:55 opkick [pdl] amba commented on issue #201: The version of cpanm in the initial failure was:... https://git.io/v1TFV
15:13 opkick [pdl] devel-chm commented on issue #201: If you put the ExtUtils::ParseXS into CONFIGURE_REQUIRES, does that fix it for you? https://git.io/v1Tb8
15:28 opkick [pdl] amba commented on issue #201: > If you put the ExtUtils::ParseXS into CONFIGURE_REQUIRES, does that fix it for you?... https://git.io/v1TNt
17:16 chm joined #pdl
23:54 jberger joined #pdl

| Channels | #pdl index | Today | | Search | Google Search | Plain-Text | summary