Perl 6 - the future is here, just unevenly distributed

IRC log for #perl6-toolchain, 2017-03-09

| Channels | #perl6-toolchain index | Today | | Search | Google Search | Plain-Text | summary

All times shown according to UTC.

Time Nick Message
07:01 domidumont joined #perl6-toolchain
09:21 domidumont joined #perl6-toolchain
09:28 domidumont joined #perl6-toolchain
09:58 domidumont joined #perl6-toolchain
16:27 lizmat joined #perl6-toolchain
16:32 lizmat joined #perl6-toolchain
17:42 domidumont joined #perl6-toolchain
20:55 sjn hey, interesting. Zef refuses to install DateTime::Parse, and Panda doesn't
20:55 sjn looks like it's because DateTime::Parse version is set to "0.0.1"
20:58 sjn aaah, it's because of the pull request i sent a few days ago
21:02 * sjn upgrades Zef
21:17 ugexe strange, I'm not sure how that pr affects anything that isn't explicitly requested as "{$short-name}:api<>..." (i.e. :api is explicitly requested as the first item over version/auth), which panda isn't capable of understanding
21:23 ugexe i'll have to dig deeper to figure out how that pr fixes this specifically
21:24 ugexe fwiw older zef on 2016.07 installed DateTime::Parse ok
21:30 ugexe sjn: there was also like a 1 day window after I accepted your pr and when lexical requires landed in rakudo where it failed to load TAP::Harness. The commit after yours addressed that. I'm thinking you just had a perfect storm of recent versions :)

| Channels | #perl6-toolchain index | Today | | Search | Google Search | Plain-Text | summary