Perl 6 - the future is here, just unevenly distributed

IRC log for #perl6-toolchain, 2017-06-16

| Channels | #perl6-toolchain index | Today | | Search | Google Search | Plain-Text | summary

All times shown according to UTC.

Time Nick Message
03:30 lizmat joined #perl6-toolchain
03:46 llfourn joined #perl6-toolchain
04:54 stmuk joined #perl6-toolchain
04:58 stmuk_ joined #perl6-toolchain
05:43 domidumont joined #perl6-toolchain
05:50 domidumont joined #perl6-toolchain
06:36 domidumont joined #perl6-toolchain
10:00 nine ugexe: sorry, no idea. The only difference should be the extra process for the wrapper script. But that doesn't even touch the precompiled modules. Maybe RAKUDO_MODULE_DEBUG output gives a clue?
12:55 perlpilot joined #perl6-toolchain
14:07 ugexe RAKUDO_MODULE_DEBUG didn't reveal anything other than its when trying to rename the .tmp precomp to its normal name
14:08 ugexe i went through all the CUR files and added :close to the .slurp's to see if it was from a handle not being closed in time, but that didnt help
14:09 ugexe worse - App::ecogen on windows I have to even delete lib/.precomp after each run. it always runs on the first but subsequent runs it gives that rename error
14:09 ugexe im starting to suspect its permissions related + however the process is spawned
14:10 ugexe like how it does `%env<ComSpec> /c`
14:10 ugexe maybe there is some other flag that needs to be used?
16:03 nine But but but on subsequent runs it shouldn't even create any precomp files?!
16:04 nine That's what is done on the first run. Later it should just read them.
16:18 ugexe good point... wonder whats causing *that* then
17:08 llfourn joined #perl6-toolchain
17:45 perlpilot joined #perl6-toolchain
19:51 ZofBot joined #perl6-toolchain
20:52 stmuk joined #perl6-toolchain
21:31 tadzik joined #perl6-toolchain
23:21 mst_ joined #perl6-toolchain
23:29 ranguard joined #perl6-toolchain

| Channels | #perl6-toolchain index | Today | | Search | Google Search | Plain-Text | summary