Perl 6 - the future is here, just unevenly distributed

IRC log for #puppet-openstack, 2012-11-09

| Channels | #puppet-openstack index | Today | | Search | Google Search | Plain-Text | summary

All times shown according to UTC.

Time Nick Message
00:14 aimon boped https://github.com/puppetla​bs/puppetlabs-nova/pull/193
00:14 aimon single commit .. much better :)
01:40 newptone joined #puppet-openstack
01:51 newptone joined #puppet-openstack
02:18 newptone left #puppet-openstack
06:30 e1mer joined #puppet-openstack
07:02 e1mer joined #puppet-openstack
07:38 e1mer joined #puppet-openstack
07:38 e1mer joined #puppet-openstack
07:58 e1mer joined #puppet-openstack
07:58 e1mer joined #puppet-openstack
08:13 e1mer joined #puppet-openstack
08:13 e1mer joined #puppet-openstack
09:27 derekh joined #puppet-openstack
10:05 e1mer joined #puppet-openstack
10:05 e1mer joined #puppet-openstack
11:48 \etc\bin joined #puppet-openstack
11:48 \etc\bin joined #puppet-openstack
16:21 pdurbin bodepd: (or anyone) do you know if comptona got your manifests to run on puppet 3.x?
16:24 pdurbin i'm still getting the "Error 400 on SERVER: Invalid parameter provider at /etc/puppet/environments/openstack/m​​odules/nova/manifests/rabbitmq.pp" error i first reported at http://irclog.perlgeek.de/cr​imsonfu/2012-11-05#i_6128062 , even with newer code that works on centos within vagrant
16:41 pdurbin JoeJulian: are you using http://forge.puppetlabs.com/puppetlabs/openstack ?
16:42 JoeJulian I'm working on it, yeah. Probably again today.
16:43 pdurbin on centos? on puppet 3?
16:43 JoeJulian yep, yep.
16:43 pdurbin awesome
16:43 pdurbin no rabbitmq problems?
16:45 JoeJulian Since I've been able to get back onto this project, I've been trying to get good patches written, merged, and onto forge. I haven't actually had a chance to try building from scratch again yet. Hoping to do that today.
16:45 pdurbin cool cool. thanks
16:48 pdurbin bodepd: you had asked me to try it on puppet 2.x but we're on 3.x and it's not easy for me to test. and i can't see us downgrading anyway...
17:43 bodepd pdurbin: can you send me a stack trace? (I think you may have already)
17:43 bodepd it feels like a bug in Puppet 3.0
17:48 comptona joined #puppet-openstack
18:22 pdurbin bodepd: you asked but i never gave you once. running --trace now
18:22 pdurbin comptona: hi there. are you on puppet 2.x or 3.x? i forget
18:22 comptona 2.x
18:23 pdurbin drat ;)
18:23 comptona we still have a lot of centos5 laying around
18:23 comptona although all my openstack stuff is on centos6
18:23 pdurbin cool. and are you using the latest and greatest from bodepd?
18:24 comptona not yet
18:24 pdurbin ok. but you plan to
18:24 comptona I've run into a blocking bug with horizon that I haven't figured out how to deal with
18:24 comptona yep
18:24 pdurbin ok
18:24 pdurbin and are you rabbitmq or qpid?
18:24 comptona I can't tell if the problem is with horizon itself, or with the way the modules set up keystone, etc. etc.
18:24 comptona rabbitmq, although I don't particularly care
18:25 comptona that was just the first thing I could get to work
18:25 pdurbin oh right. you mentioned special patches you made for rabbitmq
18:25 comptona just little nova.conf stuff to point everything in the right direction
18:26 pdurbin ok
18:26 pdurbin blocking bug with horizon? with which version of the puppet module?
18:26 comptona HEAD as of 2-3 days ago
18:26 pdurbin ok
18:26 bodepd what is the issue?
18:26 comptona but again, it might not be the module
18:27 comptona it's the same as this guy's: https://answers.launchpad.n​et/horizon/+question/212376
18:28 comptona I've tried disabling PKI as instructed, but it didn't seem to help, and then I had some other stuff to take care of so I'll be getting back to it this afternoon
19:19 * JoeJulian doesn't like the dependency version constraint syntax. My pull request contains the dependency constraint for the 2. version of stdlib that would contain the parser I need, but that version requirement would also be met by 3.* which may not contain the required parser.
20:51 e1mer joined #puppet-openstack
20:51 e1mer joined #puppet-openstack
21:15 nanliu joined #puppet-openstack
21:17 comptona JoeJulian++
21:18 comptona there have been lots of times where I've wanted to be able to say "version => 2 <= x < 3" for python stuff
21:42 pdurbin bodepd: sent the --trace to the mailing list
22:23 JoeJulian I emailed Pieter van de Bruggen who has submitted patches for the semantic versioning in ruby and he confirmed there is no support for range disjunctions. I've filed a feature request. http://projects.puppetlabs.com/issues/17545
22:33 comptona nice
22:49 bodepd JoeJulian: maybe use Puppetfile and librarian puppet to install the exact versions of things you need?
22:50 bodepd JoeJulian: that is definitely a bigger problem...
23:17 bodepd JoeJulian: what is the exact error you are seeing
23:17 bodepd ?
23:35 bodepd joined #puppet-openstack
23:53 aimon boped I intend to resurrect the nova-volume manifests in openstack module
23:53 aimon any reservations?

| Channels | #puppet-openstack index | Today | | Search | Google Search | Plain-Text | summary