Perl 6 - the future is here, just unevenly distributed

IRC log for #puppet-openstack, 2012-11-10

| Channels | #puppet-openstack index | Today | | Search | Google Search | Plain-Text | summary

All times shown according to UTC.

Time Nick Message
00:21 bodepd go ahead.
00:21 bodepd just trigger its usage with flags like quantum/nova-networks
00:21 bodepd did cinder not work for you?
00:22 JoeJulian No error, but you didn't want the version 3 stdlib so that means I'd have to require >=2.6.0. 3.1.1 is >= 2.6.0 so even though it doesn't have the parser, it would satisfy the requirement.
00:25 bodepd ah, gotcha.
00:25 bodepd there is a fix for that.
00:26 bodepd you can specify 2.x
00:26 bodepd instead of >=
00:26 bodepd this causes librarian-puppet to blow up though :(
00:27 JoeJulian c
00:27 bodepd does using that syntax resolve your issue?
00:28 bodepd https://github.com/rodjek/librarian-puppet/issues/56
00:28 bodepd I kind of want to not use Puppet librarian and just write a scipt that does its actions
00:29 bodepd kind of like other_repos.yaml (for folks who know what that means)
00:29 JoeJulian Not really. Sure, I could just set the dependency to 2.6.0 - 3.0.0 but I'm already using stdlib 3.1.1 and I've found no reason for me to downgrade (except, possibly, this).
00:29 bodepd well, then it works for you.
00:29 bodepd why do you want to set an upper limit?
00:30 bodepd also the module tool should notice that you already have something installed that meets the req and do nothing.
00:32 JoeJulian There are two release versions of puppetlabs-stdlib (and v4.x on the way). The requirement that I'm adding would be satisfied by either major version, but there is a minor version requirement either way. If I went >=3.2.0 there would be no problem as all versions >=3.2.0 will satisfy.
00:32 JoeJulian Requiring the 2.x release means that 2.6 is the first version that will have the parser.
00:33 bodepd damn.
00:33 JoeJulian But versions between 2.99999999999.9999999999999 and 3.2.0 won't have the parser.
00:33 bodepd deps are complicated :(
00:33 JoeJulian hehe
00:34 bodepd its probably my fault for supporting 2.6.x
00:34 bodepd its not even officially supported anymore.
00:34 JoeJulian :)
00:35 JoeJulian Maybe we should version it the same way and have a 2.x release and a 3.x release. Each one could then specify the specific dependency for it's version.
00:38 bodepd or just preinstall the version you care about first
00:38 bodepd and it should work?
00:40 JoeJulian I'm not worried about myself. I'm trying to make my pull request usable for everybody.
02:08 e1mer joined #puppet-openstack
03:59 e1mer joined #puppet-openstack
07:04 aimon hoped I added the reserved_host_memory_mb & reserved_host_disk_mb options to puppetlabs-nova and puppetlabs-openstack modules.. PR on both projects
07:05 aimon note that spec will fail for puppetlabs-openstack unless changes exist for puppetlabs-nova
07:07 aimon *boped that was for you.. damned that h
07:12 aimon I'll be adding ram_allocation_ratio & cpu_allocation_ratio also
07:29 aimon ok I closed both of those..  jtopjian pointed out that extra config options should be added externally via nova_config etc.
07:29 aimon thats much easier!
07:30 aimon for some reason I had the misconception that the confgi was realized all at once.. however it appears that each line is handled separately.. this is very cool
08:11 e1mer joined #puppet-openstack
08:11 bodepd joined #puppet-openstack
08:11 nanliu joined #puppet-openstack
08:11 romero joined #puppet-openstack
08:11 JoeJulian joined #puppet-openstack
08:11 aimon joined #puppet-openstack
08:11 sbadia joined #puppet-openstack
08:11 pdurbin joined #puppet-openstack
08:19 e1mer joined #puppet-openstack
09:17 dachary joined #puppet-openstack
09:46 e1mer joined #puppet-openstack
09:46 e1mer joined #puppet-openstack
17:18 comptona joined #puppet-openstack
18:38 dachary joined #puppet-openstack
22:05 e1mer joined #puppet-openstack
22:05 e1mer joined #puppet-openstack
22:23 aimon hey thx for the info/help jtopjian
22:23 aimon saved me some extra work ;)
22:55 JoeJulian pdurbin: Sure enough, https://github.com/puppetlabs/puppetlabs-rabbitmq/blob/master/lib/puppet/type/rabbitmq_user.rb doesn't have a provider param. I can't find whether or not it should be inherited somewhere though (one of the things that drives me nuts in ruby). It doesn't look like it is.
23:14 dachary joined #puppet-openstack

| Channels | #puppet-openstack index | Today | | Search | Google Search | Plain-Text | summary