Perl 6 - the future is here, just unevenly distributed

IRC log for #puppet-openstack, 2017-05-15

| Channels | #puppet-openstack index | Today | | Search | Google Search | Plain-Text | summary

All times shown according to UTC.

Time Nick Message
00:33 redaudit joined #puppet-openstack
01:08 acormier joined #puppet-openstack
01:13 rwsu joined #puppet-openstack
01:24 acormier joined #puppet-openstack
01:48 ilbot3 joined #puppet-openstack
01:48 Topic for #puppet-openstack is now CI Status: RED - all Ubuntu integration jobs fail | Puppet OpenStack modules http://docs.openstack.org/developer/puppet-openstack-guide/
03:35 jaganathan joined #puppet-openstack
04:16 skramaja joined #puppet-openstack
05:49 ratailor joined #puppet-openstack
06:07 openstackstatus joined #puppet-openstack
06:23 gfidente joined #puppet-openstack
06:23 gfidente joined #puppet-openstack
06:25 jaganathan joined #puppet-openstack
06:35 yprokule joined #puppet-openstack
06:46 oidgar joined #puppet-openstack
06:55 openstackstatus joined #puppet-openstack
06:57 openstack joined #puppet-openstack
06:57 openstack joined #puppet-openstack
07:00 chem joined #puppet-openstack
07:21 bogdando joined #puppet-openstack
07:24 openstackgerrit Rajesh Tailor proposed openstack/puppet-nova master: Trivial-Fix: Fix typos  https://review.openstack.org/464553
07:47 rcernin joined #puppet-openstack
07:49 bogdando joined #puppet-openstack
07:53 agurenko joined #puppet-openstack
07:57 jpich joined #puppet-openstack
08:09 jaosorior joined #puppet-openstack
08:23 dgurtner joined #puppet-openstack
08:23 dgurtner joined #puppet-openstack
08:29 rpittau joined #puppet-openstack
08:35 dgurtner joined #puppet-openstack
08:35 dgurtner joined #puppet-openstack
08:49 shardy joined #puppet-openstack
09:02 social joined #puppet-openstack
09:38 ratailor Hi
09:39 ratailor Could anybody tell me why this https://review.openstack.org/#/c/464553/ is failing on gate-puppet-nova-puppet-beaker-rspec-ubuntu-xenial. Its only typo fix.
09:39 ratailor Its says "Error: Failed to apply catalog: Execution of '/usr/bin/openstack project list --quiet --format csv --long' returned 1: 'Token' object has no attribute 'get_access' (tried 37, for a total of 170 seconds)"
10:07 abishop joined #puppet-openstack
10:11 xingchao joined #puppet-openstack
10:12 therve ratailor, The ubuntu packages are broken somehow
10:12 therve I don't think it was figured out how yet
10:13 ratailor therve, so there is nothing wrong with my patch :)
10:13 ratailor therve, Thanks!
10:13 therve Well, I didn't say that :)
10:29 karthiks joined #puppet-openstack
10:44 vaishali joined #puppet-openstack
10:44 basilAB joined #puppet-openstack
11:22 vnogin joined #puppet-openstack
11:45 dgurtner joined #puppet-openstack
11:45 dgurtner joined #puppet-openstack
11:52 dprince joined #puppet-openstack
11:59 shardy_ joined #puppet-openstack
12:05 openstackgerrit Ricardo Noriega proposed openstack/puppet-openstack-integration master: Add L2GW service to scenario004  https://review.openstack.org/460080
12:10 acormier joined #puppet-openstack
12:18 vnogin joined #puppet-openstack
12:20 ansmith joined #puppet-openstack
12:30 dprince joined #puppet-openstack
12:51 khappone joined #puppet-openstack
13:20 xingchao joined #puppet-openstack
13:24 makowals_ joined #puppet-openstack
13:28 makowals joined #puppet-openstack
13:28 vnogin joined #puppet-openstack
13:35 fultonj joined #puppet-openstack
13:35 xingchao joined #puppet-openstack
13:37 dtantsur any fuel folks around? is CI failure on https://review.openstack.org/#/c/459955/ real?
13:40 mkarpin dtantsur: Hi, nope, it's ok
13:41 xingchao joined #puppet-openstack
13:42 dtantsur thnx
14:01 agurenko joined #puppet-openstack
14:09 acormier joined #puppet-openstack
14:12 dgurtner joined #puppet-openstack
14:12 dgurtner joined #puppet-openstack
14:13 acormier_ joined #puppet-openstack
14:15 vnogin joined #puppet-openstack
14:28 ratailor joined #puppet-openstack
14:31 dfisher joined #puppet-openstack
14:35 derekh joined #puppet-openstack
14:39 derekh joined #puppet-openstack
14:39 social joined #puppet-openstack
14:41 xarses joined #puppet-openstack
14:42 andreww joined #puppet-openstack
14:54 fultonj joined #puppet-openstack
15:01 dgurtner joined #puppet-openstack
15:24 dgurtner joined #puppet-openstack
15:28 xingchao joined #puppet-openstack
15:34 makowals joined #puppet-openstack
15:37 openstackgerrit Pradeep Kilambi proposed openstack/puppet-ceilometer master: Add deprecate warning to ceilometer::client  https://review.openstack.org/464672
15:51 jaosorior joined #puppet-openstack
16:11 vnogin joined #puppet-openstack
16:14 dprince joined #puppet-openstack
16:15 jaganathan joined #puppet-openstack
16:15 vnogin joined #puppet-openstack
16:43 openstackgerrit Pavel Gluschak (scsnow) proposed openstack/puppet-cinder master: Added support for VStorage backup driver  https://review.openstack.org/464173
17:12 vnogin joined #puppet-openstack
17:29 xingchao joined #puppet-openstack
17:36 karthiks joined #puppet-openstack
18:12 vnogin joined #puppet-openstack
18:34 dgurtner joined #puppet-openstack
18:34 dgurtner joined #puppet-openstack
18:44 vnogin joined #puppet-openstack
18:47 EmilienM mwhahaha: do we want to disable voting on this one too?
18:47 mwhahaha beaker? yea
18:47 mwhahaha EmilienM: I assume you're refering to https://review.openstack.org/464671
18:50 EmilienM mwhahaha: nice. +1
18:53 toMeloos joined #puppet-openstack
18:58 bogdando joined #puppet-openstack
19:18 xarses joined #puppet-openstack
19:23 xingchao joined #puppet-openstack
19:34 karthiks joined #puppet-openstack
19:58 acormier joined #puppet-openstack
20:18 lhinds joined #puppet-openstack
20:19 pliu joined #puppet-openstack
20:20 rnoriega joined #puppet-openstack
20:28 finchd joined #puppet-openstack
20:34 xingchao joined #puppet-openstack
20:37 vnogin joined #puppet-openstack
20:57 vnogin joined #puppet-openstack
21:18 vnogin joined #puppet-openstack
21:46 vnogin joined #puppet-openstack
21:52 xingchao joined #puppet-openstack
21:52 gfidente in case someone is around
21:53 gfidente how come my metadata.json says <3.0.0 and I get tag 3.0.0 of a certain module installed?
22:04 acormier joined #puppet-openstack
22:17 dixiaoli joined #puppet-openstack
22:48 fultonj gfidente++
22:49 gfidente EmilienM ^^ hey it seems Puppetfile in puppet-openstack-integration points to version 3.0.0 of apt and concat
22:49 gfidente which causes errors to puppet-ceph spec
22:51 gfidente as that expects both to be < 3.0.0
22:51 gfidente did we need 3.0.0 for a specific reason?
22:55 gfidente EmilienM it seems like it was initially the OpenStack Proposal Bod advacing the tags
22:55 openstackgerrit Alex Schultz proposed openstack/puppet-nova master: Properly handle arrays for enabled_perf_events  https://review.openstack.org/464771
22:56 gfidente I suppose that is some automation which doesn't use puppet-ceph ?
22:56 gfidente mwhahaha ^^ maybe you know something about that too
22:57 mwhahaha gfidente: how ar eyou checking out your modules?
22:57 mwhahaha gfidente: only using 'puppet module isntall' will honor those restrictions. thinks like r10k assume you've handled that dependency stuff
22:57 mwhahaha puppet-librarian used to try and do the version lookups and people hated it
22:58 gfidente ok I am not going to get into that conversation :)
22:58 gfidente instead
22:58 xarses https://github.com/openstack/puppet-ceph/commit/998e023d8f20584220d8c4ab2eed27541cd7ef98
23:00 mwhahaha gfidente: so in our CI, we use https://github.com/openstack/puppet-openstack-integration/blob/master/Puppetfile#L177
23:00 mwhahaha gfidente: which is generated by what passes and not using the constraints from metadata.json
23:00 gfidente metadata.json of p-o-i itself?
23:01 mwhahaha gfidente: no we have a Puppetfile that we use with r10k to install all the dependencies
23:01 mwhahaha gfidente: https://github.com/openstack/puppet-openstack-integration/blob/master/external_modules.txt is the list of our external modules and we've got a job that runs to get the latest released version.
23:01 mwhahaha gfidente: these versions are put into the Puppetfile which we use to populate CI
23:01 gfidente ok I see ,3.0.0 was added recently to apt and concat
23:02 gfidente and puppet-ceph doesn't work with those
23:02 mwhahaha yea they do
23:02 gfidente it works with both to 2.x
23:02 mwhahaha we just have bad version caps in puppet-ceph
23:02 mwhahaha it also works with 3.0.0 because that's what our CI uses :D
23:03 gfidente it's failing in CI from what I can tell
23:03 gfidente https://review.openstack.org/#/c/462991/
23:03 mwhahaha gfidente: link?
23:04 mwhahaha oh it works, but our unit tests are bad
23:04 mwhahaha we gate those version bumps on scenarios, not unit tests
23:05 gfidente "our" unit tests in puppet-ceph you mean?
23:05 mwhahaha gfidente: http://logs.openstack.org/91/462991/1/check/gate-puppet-ceph-puppet-unit-latest-centos-7/42be14a/console.html#_2017-05-15_17_28_05_372417 points to bad facts in the unit tests
23:05 mwhahaha gfidente: yes
23:05 gfidente those unit tests work with 2.x though
23:05 mwhahaha yea because they added an os check
23:06 gfidente so indeed out of ~900 tests "only" ~200 fail with 3.0.0
23:07 mwhahaha gfidente: so probably what happened is they switch the fact they were using for the os
23:07 mwhahaha gimme a sec and i'll find the problem
23:10 mwhahaha looks like $keyserver because required (that's one of the problems)
23:10 mwhahaha we can probably just revert the newer version of apt for now since it might take a bit to fixup all these things
23:11 gfidente though I tried running apt/2.4 and concat/3
23:11 gfidente and there were some failures as well
23:13 mwhahaha hmm we pinned to 3.0.0
23:13 mwhahaha that's weird
23:14 vnogin joined #puppet-openstack
23:14 mwhahaha we pinned concat because of postfgres
23:14 mwhahaha and apt has been 3.0.0 for over a month
23:14 mwhahaha have we just not been looking?
23:15 mwhahaha https://github.com/openstack/puppet-openstack-integration/commit/2b57a24d35a833ce543e139c2d04bcb229d1a0be
23:15 * mwhahaha just blames EmilienM
23:18 mwhahaha Hunner: what does include ::apt require a keyserver now?
23:19 openstackgerrit Alex Schultz proposed openstack/puppet-openstack-integration master: Pin apt to 2.4.0  https://review.openstack.org/464777
23:22 mwhahaha looks like https://github.com/puppetlabs/puppetlabs-apt/blob/3.0.0/data/common.yaml#L3 is not getting picked up in the testing anymore
23:22 mwhahaha wonder if puppet broke something
23:22 Hunner What version of puppet?
23:22 mwhahaha Hunner: latest and 4.5
23:24 gfidente mwhahaha thanks for helping fwiw
23:24 mwhahaha Hunner: we're also running into issues with $facts['osfamily'] it looks like
23:24 mwhahaha Hunner: http://logs.openstack.org/91/462991/1/check/gate-puppet-ceph-puppet-unit-latest-centos-7/42be14a/console.html#_2017-05-15_17_28_05_372566
23:24 mwhahaha Hunner: http://logs.openstack.org/91/462991/1/check/gate-puppet-ceph-puppet-unit-4.5-centos-7/272c45a/console.html#_2017-05-15_17_28_30_983232 4.5 doesn't like the data thing
23:24 gfidente I think osfamily is behaving differently in 4.5 and lates?
23:25 gfidente yeah
23:25 Hunner mwhahaha: hmm. I know there is a bug with data-in-modules in 4.4.x fixed in 4.5.0 https://tickets.puppetlabs.com/browse/PUP-6230
23:25 Hunner But also https://github.com/puppetlabs/puppetlabs-apt/blob/3.0.0/metadata.json#L36
23:26 Hunner hmm
23:26 mwhahaha Hunner: ok we're goign to go back to 2.4.0 but it looks like there's a problem with latest and $facts['osfamily']
23:26 mwhahaha Hunner: cause that's 4.10.1
23:26 Hunner oh ruby 2.4?
23:26 mwhahaha no
23:27 mwhahaha runy 2.0.0
23:27 mwhahaha ruby\
23:28 Hunner For the osfamily thing, I wonder if puppet 4.10.1 messed something up
23:28 Hunner https://docs.puppet.com/puppet/4.10/release_notes.html says it "fixed" hiera lookups
23:28 mwhahaha probably
23:29 mwhahaha cause the errors are all related to os support and that's using $facts['osfamily'] and we're using rspec-puppet-facts
23:29 * mwhahaha shrugs and goes back to other things
23:30 openstackgerrit Alex Schultz proposed openstack/puppet-openstack-integration master: Pin apt to 2.4.0  https://review.openstack.org/464777
23:31 gfidente mwhahaha ok maybe with apt working there are fixes we could use in puppet-ceph to cope with concat 3
23:31 gfidente sounds like a plan?
23:31 mwhahaha yea
23:31 gfidente ack, thanks
23:33 Hunner mwhahaha: Is there a quick way for me to replicate this locally?
23:33 mwhahaha Hunner: bundle exec rake spec on puppet-ceph
23:34 gfidente mwhahaha well ... https://github.com/puppetlabs/puppetlabs-concat/blob/3.0.0/metadata.json#L106
23:34 mwhahaha gfidente: ok well then, i shall also revert tha tone
23:34 gfidente I am sorry guys to have uncovered
23:34 mwhahaha Hunner: whats with the 4.7 minimums?
23:35 gfidente yeah was going to ask the same
23:36 mwhahaha starting to feel like python in here
23:36 gfidente that would be 3.2 tjem
23:36 mwhahaha >=1.0.0,!=1.1.0,<2.0.0
23:36 Hunner mwhahaha: 4.4 had issues, 4.5 had other issues and is limited support, and 4.6 didn't ship in any PE versions
23:37 Hunner and 4.7 was notbad.jpg
23:37 Hunner and 4.0-4.3 don't count :P
23:37 mwhahaha Hunner: we've just been testing with 4.5 i think we have 4.8 in centosland but i'll have to check
23:38 mwhahaha 4.6.2
23:38 mwhahaha HEH
23:38 Hunner We thought about doing >= 4.5.0 (and it will very likely work anyway) but that would mean testing on PE versions that are aging and it was not fun
23:38 Hunner and 4.7 is LTS
23:38 mwhahaha Hunner: considering we just killed for 3 support 4 months ago...
23:38 mwhahaha Hunner: yea but we don't use PE :/
23:39 Hunner mwhahaha: LTS pe support for foss means 4.7 will still get lots of attention
23:39 Hunner even if you're not pe
23:40 mwhahaha i just remember how much of a pain it was to get teh cento s4.6.2 version (something about boost packages)
23:40 openstackgerrit Alex Schultz proposed openstack/puppet-openstack-integration master: Lower pins for apt and concat  https://review.openstack.org/464777
23:45 redaudit joined #puppet-openstack
23:46 * mwhahaha wanders off for the day

| Channels | #puppet-openstack index | Today | | Search | Google Search | Plain-Text | summary