Perl 6 - the future is here, just unevenly distributed

IRC log for #salt, 2014-09-27

| Channels | #salt index | Today | | Search | Google Search | Plain-Text | summary

All times shown according to UTC.

Time Nick Message
00:01 jalbretsen joined #salt
00:10 aquinas_ joined #salt
00:11 Eugene Where is salt-ssh expecting to find the salt-ssh.rsa file? Currently I have it in /root/.ssh/, but I'm getting a Permission denied
00:11 Eugene I've tested that `ssh -i ~/.ssh/salt-ssh.rsa user@host` works
00:12 aparsons joined #salt
00:15 Eugene strace says /etc/salt/pki/master/ssh/, aha. The docs aren't clear on that.
00:15 Eugene (at all)
00:15 catpig joined #salt
00:16 scbunn joined #salt
00:19 mechanicalduck_ joined #salt
00:24 mechanicalduck joined #salt
00:28 mechanicalduck_ joined #salt
00:31 bhosmer joined #salt
00:32 lpmulligan joined #salt
00:35 Zachary_DuBois left #salt
00:39 kingel joined #salt
00:40 catpig joined #salt
00:45 Eugene Grar. Of course pkg.installed doesn't work via salt-ssh
00:50 ndrei joined #salt
00:51 gtmacdonald joined #salt
00:54 gtmacdonald Hi Everyone, Has anyone build the windows minion installer recently? I'm having difficulties trying to make a 64 bit version. I can't get zmq to freeze for some reason even though it's installed.
00:59 aparsons joined #salt
01:00 ndrei joined #salt
01:05 rjc joined #salt
01:06 mrlesmithjr joined #salt
01:07 floWenoL_ joined #salt
01:16 jhujhiti is anyone using freebsd pkgng with a 'pkg' command that isn't in the default /usr/sbin location? can i change where salt expects to find this somehow?
01:32 bhosmer joined #salt
01:33 TyrfingMjolnir joined #salt
01:45 thayne joined #salt
01:55 TheThing joined #salt
01:58 tristianc joined #salt
01:59 saurabhs1 joined #salt
02:01 tristianc I want to have multiple states manage a /etc/exports. I have state A  introduce an empty /etc/exports, and state B and C that append to /etc/exports and that require state A
02:01 tristianc when state B and C run, they each rerun state A
02:02 tristianc How do I ensure that the execution is A -> B -> C instead of A -> B, A -> C
02:09 TyrfingMjolnir joined #salt
02:13 otter768 joined #salt
02:20 bhosmer joined #salt
02:21 ramishra joined #salt
02:24 Ryan_Lane joined #salt
02:37 ajprog_laptop2 joined #salt
02:42 mgw joined #salt
02:43 terinjokes joined #salt
02:45 younqcass_ joined #salt
02:48 Eugene You should be managing the file only once; with a file.managed. Build your list of exports in Pillar, not in the State.
02:49 gfa joined #salt
02:52 jaimed joined #salt
02:54 jaimed joined #salt
02:57 esogas` joined #salt
02:57 joeyparsons joined #salt
03:00 terinjokes joined #salt
03:11 gfa joined #salt
03:18 pdayton joined #salt
03:24 bezeee joined #salt
03:24 vejdmn joined #salt
03:26 TheThing joined #salt
03:29 ramishra joined #salt
03:46 Ryan_Lane joined #salt
03:49 druonysus joined #salt
03:49 druonysus joined #salt
04:09 bhosmer joined #salt
04:14 rcsheets joined #salt
04:15 mikepea joined #salt
04:16 goki_____ joined #salt
04:17 neilf_____ joined #salt
04:17 thayne joined #salt
04:19 scalability-junk joined #salt
04:22 hillna joined #salt
04:24 gamingrobot joined #salt
04:25 akitada__ joined #salt
04:27 ajolo joined #salt
04:30 lkannan joined #salt
04:31 acabrera joined #salt
04:31 abele joined #salt
04:31 basepi joined #salt
04:39 CaptTofu joined #salt
04:40 jslatts joined #salt
04:41 tkharju joined #salt
04:43 doriftoshoes joined #salt
04:46 JordanTesting joined #salt
04:46 ikanobori joined #salt
04:50 imanc joined #salt
04:51 MTecknology I'm trying to use a github repo in salt. I'm using the https:// version since I don't want to set up ssh authentication. I'm seeing the message  2014-09-26 23:45:16,620 [salt.loaded.int.fileserver.gitfs            ][WARNING ] GitPython exception caught while fetching: 'Error when fetching: fatal: HTTP request failed' returned exit status 2: None
04:53 fxdgear joined #salt
04:59 mrlesmithjr joined #salt
05:00 MTecknology seems like it should be working just perfectly fine and great
05:11 MTecknology ah... certs
05:12 FarrisG joined #salt
05:14 mrlesmithjr joined #salt
05:22 MTecknology Are there any debs for 2014.7?
05:23 Vye MTecknology: they usually don't release packages until the official release. :(
05:25 MTecknology I guess I get to re-learn how to set up an apt repo at home. I did it at work a year or so ago
05:38 n8n joined #salt
05:42 acabrera joined #salt
05:44 catpigger joined #salt
05:48 scuwolf joined #salt
05:58 bhosmer joined #salt
06:08 scuwolf joined #salt
06:10 aquinas joined #salt
06:10 aquinas_ joined #salt
06:14 MTecknology crap... I forgot how to build salt
06:14 MTecknology It's been too long
06:16 holler_ joined #salt
06:20 holler_ hello, I have a project where a requirements.txt file is installed and all is fine and dandy except it is not installing a package that uses the -e syntax, L9 http://dpaste.com/23F4DPX
06:20 holler_ anyone know why that would be/
06:20 holler_ ?
06:33 babilen holler_: So ... you left out the most important bit of information: What happens if you run it?
06:35 holler_ babilen: it installs everything in my requirements.txt except the -e
06:35 holler_ which I just looked up and it appears you can do pip.installed: - editable: git+https://somepackage
06:36 babilen You can indeed
06:37 babilen That entry still constitutes a valid entry in a requirements file, doesn't it?
06:42 holler_ yes
06:42 holler_ so Im not sure why it doesnt install it
06:42 babilen AFAICT the requirements file is just passed to the pip command with "--requirement=/path/to/file" -- Does it work if you run pip manually?
06:52 babilen holler_: Does it?
06:56 Sweetsha1k joined #salt
06:56 bhosmer joined #salt
06:58 holler_ babilen: yes it does if I do it manually
06:59 holler_ thats one of the manual steps I still need to automate
07:01 babilen holler_: Please run the minion in debug mode and show us the exact command it is running and run it manually to verify its behaviour.
07:01 holler_ babilen: how do I run in debug mode?
07:02 holler_ the behavior is that it doesnt show any errors but that 1 package is not installed whereas all the others in requirements.txt are installed
07:02 babilen You stop the minion and then run "salt-minion -ldebug"
07:03 babilen Oh, you ran the *exact* command salt is running already and verified that it behaves the same?
07:03 babilen (re: "the behavior is that it doesnt show any errors but that 1 package is not installed whereas all the others in requirements.txt are installed")
07:03 masm joined #salt
07:03 babilen Which was the command and how did you find it without running the minion in debug mode?
07:11 babilen holler_ is obviously using an RFC 2549 compliant uplink
07:13 holler_ babilen: here is the django/init.sls again, I separated the editable out but that seems unmanageable if you have a bunch of them
07:13 holler_ http://dpaste.com/1N652W4
07:13 holler_ all Im doing is running "vagrant up" on a fresh install
07:13 holler_ its a bitch bc it takes like 10-15 minutes so testing is a pain
07:13 babilen Ah, the power of vbox. Yes, I remember.
07:13 funzo_ joined #salt
07:13 holler_ I dont know if there is another way to test?
07:14 holler_ after its done can I test commands inside the vm?
07:16 babilen Let me do it
07:17 babilen (and consider getting a linux system for testing, you'll save a lot of time)
07:18 babilen What are "python-essentials" ?
07:18 babilen ENOPACKAGE
07:19 babilen There is no "myrepo" repository on GH that I can find.
07:24 MTecknology heh... apparently python-git doesn't satisfy gitfs_remotes in 2014.7... :S
07:25 MTecknology "Git fileserver backend is enabled in master config file, but could not be loaded, are pygit2 and libgit2 installed?"  but python-git is there and is supposed to satisfy that
07:26 babilen holler_: https://www.refheap.com/90754
07:27 babilen fwiw, there is little I can do if you don't talk to me. All the best and have a good day!
07:27 holler_ babilen: hey! sorry multitasking
07:28 holler_ that myrepo.git wasnt real
07:28 babilen Well, I'm off for now.
07:28 holler_ ok well thanks for helping!
07:29 babilen (and consider not multitasking if you ask other people for help)
07:35 mihait__ joined #salt
07:35 rcsheets joined #salt
07:35 mikepea joined #salt
07:35 abele joined #salt
07:35 grepory joined #salt
07:35 wavis joined #salt
07:35 akoumjian joined #salt
07:36 akitada__ joined #salt
07:40 Katafalkas joined #salt
07:41 scarcry joined #salt
07:47 bhosmer joined #salt
07:48 n8n joined #salt
07:52 gamingrobot joined #salt
07:58 EWDurbin joined #salt
08:15 n8n joined #salt
08:17 octarine joined #salt
08:19 MTecknology How do I get libgit2 in debian wheezy?
08:25 ndrei joined #salt
08:35 TheThing joined #salt
08:37 ggoZ joined #salt
08:43 grove_ joined #salt
08:46 babilen It's not packaged
08:49 babilen MTecknology: Dulwich is though. What are you trying to achieve?
08:56 CeBe joined #salt
08:57 MTecknology git file_root
08:58 MTecknology I tried using dulwich and got other errors
08:59 babilen I happily use GitPython
09:00 MTecknology I installed GitPython through pip
09:00 MTecknology I'm seeing this - 2014-09-27 03:58:05,025 [salt.loaded.int.fileserver.gitfs            ][ERROR   ] Exception ''module' object has no attribute 'get_transport_and_path_from_url'' caught while fetching gitfs remote https://github.com/MTecknology/gitlab-formula.git
09:01 babilen I'm using the Debian packages and they work fine.
09:01 MTecknology which debian package?
09:01 MTecknology also- which version of salt?
09:02 babilen 2014.1.10 so far
09:02 MTecknology I'm using 2014.7
09:05 babilen Ah, there are no packages for that version. Requirements might also have changed, but it is a bit tricky to debug that with my lack of knowledge of 2014.7 and the scarcity of information you provided. I know that .7 changed the order in which providers will be used and will try pygit2 first.
09:05 MTecknology I couldn't get pygit2 installed
09:06 MTecknology it's 04:07... seems like a good time to go to sleep and then just fight this tomorrow.
09:21 herzi joined #salt
09:23 herzi hej hej; I guess this is some kind of FAQ: How do I install a file (init script) and only when the script is being installed/updated then execute a command ("update-rc.d initname defaults")?
09:24 babilen requisite/dependency
09:24 babilen http://docs.saltstack.com/en/latest/ref/states/requisites.html
09:25 babilen And you simply want to watch the file in the service (or define "watch_in: \n - service: initname")
09:29 Nexpro joined #salt
09:34 snuffeluffegus joined #salt
09:50 younqcass_ joined #salt
10:02 mik3 sup
10:02 mik3 whoops, wrong channel. :)
10:02 mik3 0500 right now
10:12 martoss joined #salt
10:14 martoss1 joined #salt
10:15 martoss joined #salt
10:15 bgdnlp joined #salt
10:15 martoss joined #salt
10:17 bgdnlp hi guys. new to salt, learning. running masterless (salt-call --local). Relevant config: http://pastebin.com/Enb7WewG . Can someone please explain to me why do I get "No matching sls found for 'php55' in env 'base'" with that config?
10:18 bgdnlp manual says that "php55/init.sls" should be treated as "php55". right? what am I getting wrong?
10:21 jalaziz joined #salt
10:22 martoss joined #salt
10:25 bhosmer joined #salt
10:25 martoss1 joined #salt
10:26 n8n joined #salt
10:26 jalaziz_ joined #salt
10:29 Nexpro1 joined #salt
10:36 jalaziz joined #salt
10:40 bgdnlp got it. the include is wrong. message sounds a bit misleading I think, but fixing the include worked
10:46 bgdnlp is there a known issue with cmd.run(creates)? because my CentOS 6 says I'm running version 2014.10.0, but the command still runs even if the file specified by creates exists
10:46 jalaziz joined #salt
10:47 peters-tx joined #salt
10:49 glyf joined #salt
10:49 babilen bgdnlp: You are almost certainly running 2014.1.10 not 2014.10.0
10:49 babilen (and creates is therefore not available)
10:50 bgdnlp ok... I need coffee... thanks
10:50 glyf joined #salt
10:50 GnuLxUsr joined #salt
10:54 __number5__ joined #salt
10:56 babilen bgdnlp: Just use "unless: ..." with some "does file exist?" test command.
10:56 jalaziz joined #salt
10:57 babilen (e.g. "file /path/to/file", "ls /path/to/file", "test -e /path/to/file" (that requires shell: '/bin/bash'), ...)
11:00 ikanobori joined #salt
11:03 babilen Oh, no it works with dash too. Might want to check your shell grain on minions and use that then.
11:07 jalaziz joined #salt
11:08 bgdnlp aye, that's what I did, thank you. "test -f /path/to/file"
11:10 bhosmer_ joined #salt
11:12 jalaziz joined #salt
11:19 bgdnlp btw, test doesn't require bash. you can find it in /usr/bin/test along with /usr/bin/[. it's just that bash uses it's own internal version, but any shell can use it, as long as it's in $PATH
11:47 mapu joined #salt
12:07 diegows joined #salt
12:11 Nazzy joined #salt
12:24 intellix joined #salt
12:30 glyf joined #salt
12:40 oz_akan joined #salt
13:04 khaije|io joined #salt
13:06 khaije|io hi, I'm trying to get started using salt-cloud w/ digitalocean on debian and even after updating to the packages at http://debian.saltstack.com/debian/pool/main/s/salt/ I'm still getting 'HTTPError: HTTP Error 401: Unauhorized' errors
13:07 glyf joined #salt
13:07 nkuttler khaije|io: what do you mean, what are you doing?
13:10 khaije|io nkuttler: I've created a provider w/ my personal account info and a profile w/ some simple details, when I try to create a vm on the service w/ 'salt-cloud -p khaije-digitalocean demo01'
13:11 khaije|io I've been following notes from https://www.digitalocean.com/community/tutorials/automated-provisioning-of-digitalocean-cloud-servers-with-salt-cloud-on-ubuntu-12-04 and http://salt-cloud.readthedocs.org/en/latest/topics/config.html
13:11 nkuttler khaije|io: can you dpaste the output of that command?
13:12 khaije|io sure
13:18 khaije|io http://dpaste.com/39RQTV8
13:19 khaije|io i've been at this for a few hours at this point and would appreciate even being able to rule out possible problems
13:21 nkuttler that looks kinda odd to me. i'd expect auth errors to return some usable data..
13:22 nkuttler khaije|io: can you do any of the curl examples like on https://developers.digitalocean.com/#curl ?
13:23 nkuttler i'm just wondering if your request ever reaches the api..
13:23 khaije|io havent tried, but makes sense
13:24 nkuttler khaije|io: ah, no, your creds are probably invalid
13:24 nkuttler khaije|io: just modified my cloud config locally, set an invalid key, and get the same error
13:24 khaije|io oh you have a working setup?
13:24 nkuttler yeah
13:25 nkuttler the cloud setup is a little complex, make sure to read the salt-cloud docs
13:25 seanz joined #salt
13:25 khaije|io what version do you use? are you using the personal_access_token or the api/client key ... ?
13:26 khaije|io (for provider)
13:26 nkuttler i have a client_key param in my provider config
13:26 khaije|io because of the v2 api change i'm not sure if or how the howto's/docs are outdated
13:27 nkuttler i have a client_key and an api_key
13:28 khaije|io so... sounds like all the docs and demos I've seen are still good, ok that helps to know
13:28 bhosmer joined #salt
13:29 khaije|io i'm going to reboot my api and client key and try again :)
13:29 khaije|io thanks nkuttler!
13:29 nkuttler yw
13:36 khaije|io hey looks like that was it! In switching back and forth between the v1 and the v2 schemes I somehow mixed them up - thanks again nkuttler
13:37 nkuttler \o/
13:38 oz_akan joined #salt
13:47 khaije|io hey, one final question nkuttler? which version of salt-cloud are you using?
13:47 nkuttler khaije|io: whatever the latest is, i just pip installed it
13:48 nkuttler salt-cloud==0.8.11
13:49 khaije|io okedoke, thanks!
13:49 yerbamate joined #salt
13:54 ndrei joined #salt
14:12 jslatts joined #salt
14:15 martoss1 joined #salt
14:19 rypeck joined #salt
14:22 Deevolution joined #salt
14:25 ckao joined #salt
14:33 Deevolution joined #salt
14:33 thayne joined #salt
14:39 oz_akan joined #salt
14:48 elfixit joined #salt
15:05 bhosmer joined #salt
15:06 jslatts joined #salt
15:06 ndrei joined #salt
15:08 TheThing joined #salt
15:09 ekristen joined #salt
15:10 kingel joined #salt
15:17 bhosmer joined #salt
15:24 thayne joined #salt
15:27 ndrei joined #salt
15:33 ndrei joined #salt
15:33 martoss1 joined #salt
15:39 oz_akan joined #salt
15:40 mechanicalduck joined #salt
15:41 oz_akan joined #salt
15:45 P0bailey joined #salt
15:56 ndrei joined #salt
15:59 Katafalkas joined #salt
15:59 younqcass joined #salt
16:01 to_json joined #salt
16:02 acabrera joined #salt
16:03 perfectsine joined #salt
16:11 younqcass_ joined #salt
16:11 to_json joined #salt
16:20 CeBe joined #salt
16:21 hasues joined #salt
16:31 ndrei joined #salt
16:40 wt joined #salt
16:42 oz_akan joined #salt
16:49 markm_ joined #salt
17:05 bhosmer joined #salt
17:09 thedodd joined #salt
17:09 to_json joined #salt
17:19 alanpearce joined #salt
17:29 jslatts joined #salt
17:30 imil_ joined #salt
17:30 TamCore joined #salt
17:30 andabata- joined #salt
17:30 hotbox_ joined #salt
17:32 nahamu joined #salt
17:33 oncallsucks joined #salt
17:35 glyf joined #salt
17:38 iMil joined #salt
17:39 monokrome joined #salt
17:39 thayne joined #salt
17:41 ndrei joined #salt
17:42 jdmf joined #salt
17:43 oz_akan joined #salt
17:44 MTecknology I'm on Debian 7. I updated to Salt 2014.7 to make use of some of the features. Now I'm having issues with git repos. I have GitPython==0.3.2.RC1 installed via pip and python-git and python-dulwich installed via package manager. I only have one gitfs_remote right now and when it's running, I see this in the logs: 2014-09-27 05:01:23,432 [salt.loaded.int.fileserver.gitfs       ][ERROR ]
17:44 MTecknology Exception ''module' object has no attribute 'get_transport_and_path_from_url'' caught while fetching gitfs remote https://github.com/MTecknology/gitlab-formula.git
17:45 MTecknology I'm really lost on what I'm doing wrong. :(
17:45 MTecknology babilen: ^ Here's the details you wanted in order to have a clue what I'm doing
17:45 che-arne joined #salt
17:46 akitada__ joined #salt
17:46 FarrisG joined #salt
17:46 lpmulligan joined #salt
17:46 arnoldB joined #salt
17:46 erjohnso joined #salt
17:46 MindDrive joined #salt
17:46 jeffspeff joined #salt
17:46 ghartz joined #salt
17:46 patrek joined #salt
17:46 oeuftete joined #salt
17:46 zekoZeko joined #salt
17:46 cxz joined #salt
17:46 Valdo joined #salt
17:46 sxar joined #salt
17:46 tru_tru joined #salt
17:46 gmoro joined #salt
17:46 corvus joined #salt
17:46 t0rrant_ joined #salt
17:46 lopez joined #salt
17:46 MaZ- joined #salt
17:46 davromaniak joined #salt
17:46 brain5ide joined #salt
17:46 schainks joined #salt
17:46 WesleyL joined #salt
17:46 utahcon joined #salt
17:46 lazybear joined #salt
17:46 whytewolf joined #salt
17:46 hoodow joined #salt
17:46 bretep joined #salt
17:46 sashka_u1 joined #salt
17:46 flebel joined #salt
17:46 ksalman joined #salt
17:46 SaveTheRbtz joined #salt
17:46 bernieke joined #salt
17:46 dcolish joined #salt
17:46 ede joined #salt
17:46 _dancat_ joined #salt
17:46 samed joined #salt
17:46 Blacklite joined #salt
17:46 rubenb joined #salt
17:46 ShibMcNe joined #salt
17:46 syst3mw0rm joined #salt
17:46 stotch joined #salt
17:46 amontalban joined #salt
17:46 dwfreed joined #salt
17:46 platforms joined #salt
17:46 nlb joined #salt
17:46 skullone joined #salt
17:46 marcinkuzminski joined #salt
17:46 stan_k joined #salt
17:46 crazysim joined #salt
17:46 pmcg joined #salt
17:46 tedski joined #salt
17:46 nyov joined #salt
17:46 mortis joined #salt
17:46 msil joined #salt
17:46 the_lalelu joined #salt
17:46 eculver_ joined #salt
17:46 Kenzor joined #salt
17:46 baffle joined #salt
17:47 diegows joined #salt
17:50 manytrees joined #salt
17:53 tld_wrk joined #salt
18:04 viq joined #salt
18:06 elfixit joined #salt
18:07 oz_akan joined #salt
18:08 jslatts joined #salt
18:08 kingel joined #salt
18:17 thunderbolt joined #salt
18:18 Katafalkas joined #salt
18:28 otter768 joined #salt
18:29 pppingme joined #salt
18:48 bhosmer joined #salt
18:49 alanpearce_ joined #salt
18:50 CaptinHokk joined #salt
18:54 bhosmer_ joined #salt
18:54 manfred MTecknology: sounds like you need a newer version of dulwich
18:56 MTecknology manfred: dunno what I did wrong, but I just tried again and it seems to be working until I run a highstate. When I run a highstate on a minion now, I see this in the master logs - http://dpaste.com/18VXQ62
18:58 MTecknology I have this in the master config - http://dpaste.com/0TGPZEB   According to 2014.7 docs, that seems like it should work
18:59 MTecknology manfred: sorry, apparently I didn't read
19:01 oz_akan joined #salt
19:07 tld_wrk joined #salt
19:10 alanpearce joined #salt
19:11 MTecknology Now I'm back to getting   2014-09-27 14:11:28,340 [salt.loaded.int.fileserver.gitfs            ][ERROR   ] Exception ''module' object has no attribute 'get_transport_and_path_from_url'' caught while fetching gitfs remote https://github.com/MTecknology/gitlab-formula.git
19:12 MTecknology manfred: Is dulwich 0.8.5 too old?
19:13 mgw joined #salt
19:17 tld_wrk joined #salt
19:17 ravenac95 joined #salt
19:21 manfred no idea
19:22 manfred Was just speculating, cause it sounds like the version you have installed doesn't have the function that is needed
19:25 babilen MTecknology: Didn't you say that you had *exactly* the same problem with GitPython?
19:29 MTecknology babilen: I believe so, I don't remember much of what I fought last night anymore
19:29 anotherZero joined #salt
19:35 holler_ joined #salt
19:35 MTecknology It's starting to look like I should just upgrade to debian testing
19:38 ndrei joined #salt
19:39 MTecknology or just not do git stuff yet
19:41 martoss joined #salt
19:44 martoss1 joined #salt
19:47 Hipikat joined #salt
19:51 dalexander joined #salt
19:51 CeBe joined #salt
19:53 n8n joined #salt
20:04 manfred or install it all with pip
20:07 chayak joined #salt
20:08 jms joined #salt
20:08 jms does anyone know how to return a grain item from a custom grain, I get __grain__['ad'] does not exist, thanks
20:09 jms that should be __grains__['id']
20:09 manfred salt['grain.get']('id
20:09 manfred ')
20:09 manfred ?
20:12 n8n joined #salt
20:13 glyf joined #salt
20:15 jms File "/var/cache/salt/minion/extmods/grains/vcdn1.py", line 14, in vcdn1_id     mid = salt['grain.get']('id')
20:16 babilen grains.get
20:16 CaptinHokk joined #salt
20:23 n8n joined #salt
20:25 DaveQB joined #salt
20:28 jms still does not work, what imports are you using, or do you have an example, thanks
20:29 bezeee joined #salt
20:32 oz_akan joined #salt
20:32 CaptinHokk joined #salt
20:33 Vye if you're not using jinja, wouldn't it be __salt__['grains.get']('id') ?
20:34 Vye http://docs.saltstack.com/en/latest/ref/modules/#cross-calling-modules
20:34 pppingme joined #salt
20:34 babilen should be, yeah
20:34 Vye jms: try that
20:35 babilen http://docs.saltstack.com/en/latest/topics/development/dunder_dictionaries.html
20:36 scalability-junk joined #salt
20:36 jeffrubic joined #salt
20:36 ravenac95 joined #salt
20:36 tyler-ba- joined #salt
20:36 TamCore_ joined #salt
20:37 goal joined #salt
20:37 Heggan_ joined #salt
20:37 jamesf_ joined #salt
20:37 Eliz_ joined #salt
20:37 csa__ joined #salt
20:37 Damon_ joined #salt
20:37 p2_ joined #salt
20:37 jms within a custom grain, __salt__ && __grains__ are not define by default
20:37 babilen But then if that works __grains__ should be available too (I never manage to remember which parts are available when)
20:37 peno_ joined #salt
20:38 MTecknology manfred: brilliant idea :)  ... I feel silly for not having thought of that, seems to be working perfect
20:38 aquinas__ joined #salt
20:38 lionel_ joined #salt
20:38 peters-tx0 joined #salt
20:39 JPaul joined #salt
20:40 jms Well the second like, and by test, shows it is not available in grains
20:40 jdmf joined #salt
20:40 martinp joined #salt
20:40 n8n joined #salt
20:41 octarine_ joined #salt
20:41 rypeck_ joined #salt
20:41 Kelsar_ joined #salt
20:41 CaptinHokk joined #salt
20:42 thunderbolt_ joined #salt
20:42 sirtaj_ joined #salt
20:42 mikepea_ joined #salt
20:43 asmaps_ joined #salt
20:43 bhosmer_ joined #salt
20:43 bezaban_ joined #salt
20:43 mirko_ joined #salt
20:43 a1j_ joined #salt
20:43 Ymage joined #salt
20:43 scarcry_ joined #salt
20:43 arapaho_ joined #salt
20:43 peno joined #salt
20:44 jchen joined #salt
20:44 lyddonb_ joined #salt
20:45 martoss joined #salt
20:46 khaije|io left #salt
20:46 blast_hardcheese joined #salt
20:46 MTecknology viq: Your gitlab-formula depends on states that aren't part of the repo. In particular, https://github.com/viq/gitlab-formula/blob/master/gitlab/postgresql.sls
20:47 scalability-junk joined #salt
20:47 babilen MTecknology: What does that depend on that it shouldn't?
20:48 MTecknology babilen: line 2
20:48 balltongu joined #salt
20:49 ndrei joined #salt
20:49 thayne joined #salt
20:49 babilen So, make the postgresql formula available
20:50 n8n joined #salt
20:52 MTecknology I don't know what it's supposed to have and it doesn't seem like it should depend on something else without at least explaining that
20:55 CeBe joined #salt
20:57 * babilen blames viq
20:57 MTecknology :P
20:59 glyf joined #salt
21:00 MTecknology In the past, I mutilated his formula to make it work with an outside mysql server and install correctly on debian. Upgrades will probably suck for that box, but it's been working quite well. This time, I want to do it entirely from the formula
21:06 mrlesmithjr joined #salt
21:12 wt joined #salt
21:14 mrlesmithjr joined #salt
21:20 kedo39 joined #salt
21:25 mechanicalduck joined #salt
21:27 n8n joined #salt
21:32 oz_akan joined #salt
21:32 acabrera joined #salt
21:33 glyf joined #salt
21:48 seb` joined #salt
21:49 kingel joined #salt
21:49 terinjokes joined #salt
21:52 jalbretsen joined #salt
22:04 glyf joined #salt
22:13 rattmuff joined #salt
22:17 thayne joined #salt
22:28 dccc joined #salt
22:32 bhosmer_ joined #salt
22:33 oz_akan joined #salt
22:36 aquinas joined #salt
22:37 morsik joined #salt
22:37 morsik hello there
22:37 morsik how can i force salt to use fqdn when registering?
22:37 morsik (or maybe it's better not to use fqdn?)
22:38 ze- joined #salt
22:41 aquinas_ joined #salt
22:42 morsik or shoud i use append_domain on centos? (it's registers as 'host' instead of 'host.example.com', while debian registered as 'anotherhost.example.com')
22:49 kingel joined #salt
22:52 bhosmer joined #salt
22:53 basepi joined #salt
23:10 aparsons joined #salt
23:12 fbettag joined #salt
23:12 fbettag morning
23:13 younqcass joined #salt
23:13 wendall911 joined #salt
23:13 fbettag big kudos from me guys, i've been using cfengine for almost 2 decades now, salt is really a fresh perspective
23:17 iggy We are fans too
23:17 fbettag take a compliment
23:19 diegows joined #salt
23:20 fbettag iggy: but in any case, i'll be migrating a few racks to salt over the weekend and give it a fair shot as to power/cpu usage
23:20 fbettag anything ruby used so much cpu that we noticed it on the power invoice
23:23 manfred nice :)
23:24 fbettag manfred: i'll be happy to see cfengine install salt on all nodes and have it disable itself ;)
23:25 fbettag (or at least i'll comment that group from cfe to not to anything)
23:26 bbradley has anyone had success with the new gpg renderer?
23:26 manfred that would be fun
23:28 jslatts joined #salt
23:34 oz_akan joined #salt
23:41 mrlesmithjr joined #salt
23:44 mrlesmit_ joined #salt
23:51 tinuva joined #salt
23:55 tkharju joined #salt

| Channels | #salt index | Today | | Search | Google Search | Plain-Text | summary