Perl 6 - the future is here, just unevenly distributed

IRC log for #salt, 2015-12-26

| Channels | #salt index | Today | | Search | Google Search | Plain-Text | summary

All times shown according to UTC.

Time Nick Message
00:03 amcorreia joined #salt
00:08 yomilk joined #salt
00:15 jaybocc2 joined #salt
00:16 om joined #salt
00:24 CeBe joined #salt
00:25 NotreDev joined #salt
00:33 NotreDev left #salt
00:33 justanotherelf joined #salt
00:33 abednarik joined #salt
00:35 wenxin joined #salt
00:39 otter768 joined #salt
00:47 jaybocc2 joined #salt
01:01 s0undt3ch joined #salt
01:02 johnkeates left #salt
01:06 kusams joined #salt
01:39 trouble_ joined #salt
01:41 ALLmightySPIFF joined #salt
01:41 trouble_ G'day, does anyone know when the next version of Salt - Boron is expected to be released?
01:54 macker joined #salt
01:59 jaybocc2 joined #salt
02:07 amcorreia joined #salt
02:10 malinoff joined #salt
02:14 favadi joined #salt
02:20 dendazen joined #salt
02:20 subsignal joined #salt
02:27 mdupont joined #salt
02:40 otter768 joined #salt
02:45 mdupont joined #salt
02:53 catpigger joined #salt
02:58 jaybocc2 joined #salt
03:10 TTimo getting a windows salt minion spun up on ec2 is turning into a bit of a challenge
03:10 TTimo even with the docs on the saltstack website
03:11 TTimo I got the VM spun up, looks like winrm got enabled correctly and is listening on 5986 https
03:11 TTimo port is open in the firewall
03:11 TTimo but no pickup by salt-cloud
03:23 subsignal joined #salt
03:38 quasiben joined #salt
03:39 racooper joined #salt
03:42 ALLmightySPIFF joined #salt
03:46 garphy`aw joined #salt
03:53 scoates joined #salt
04:10 justanotherelf joined #salt
04:14 kusams joined #salt
04:23 justanotherelf joined #salt
04:28 anmol joined #salt
04:41 otter768 joined #salt
05:18 aa_ joined #salt
05:19 colegatron joined #salt
05:21 nyx_ joined #salt
05:24 garphy`aw joined #salt
05:25 subsignal joined #salt
05:26 shaggy_surfer joined #salt
05:40 favadi joined #salt
05:41 tmclaugh[work] joined #salt
06:26 subsignal joined #salt
06:35 cwyse__ joined #salt
06:41 otter768 joined #salt
06:44 ALLmightySPIFF joined #salt
06:54 malinoff joined #salt
06:54 subsignal joined #salt
07:13 jaybocc2 joined #salt
07:14 TyrfingMjolnir joined #salt
08:18 jaybocc2 joined #salt
08:25 baweaver joined #salt
08:31 ubikite joined #salt
08:31 ubikite joined #salt
08:34 Omen joined #salt
08:34 Omen left #salt
08:41 cberndt joined #salt
08:42 otter768 joined #salt
08:53 linjan joined #salt
08:54 jaybocc2 joined #salt
09:06 trouble_ joined #salt
10:14 baweaver joined #salt
10:21 slav0nic joined #salt
10:42 subsignal joined #salt
10:43 otter768 joined #salt
10:52 evle joined #salt
10:55 jaybocc2 joined #salt
10:56 mattiasr joined #salt
10:59 cberndt joined #salt
11:20 colegatron joined #salt
11:29 ggoZ joined #salt
11:43 subsignal joined #salt
11:55 Fiber^ joined #salt
12:30 amcorreia joined #salt
12:44 otter768 joined #salt
12:53 linjan joined #salt
12:56 jaybocc2 joined #salt
13:05 abednarik joined #salt
13:10 quasiben joined #salt
13:22 micko joined #salt
13:33 UForgotten joined #salt
13:45 subsignal joined #salt
13:51 cyborglone joined #salt
13:57 nyx_ joined #salt
14:02 wenxin joined #salt
14:05 PsionTheory joined #salt
14:06 masterkorp So my salt-master is not recognizing my roster file
14:10 babilen master and roster?
14:10 masterkorp yeah
14:10 * babilen only ever used that in the context of salt-ssh
14:11 masterkorp http://pastebin.com/QasKmeVL
14:11 masterkorp babilen: yeah
14:11 masterkorp i use salt-ssh and have the master on?
14:12 masterkorp and when I run  sudo salt-ssh -i gohan test.ping
14:12 masterkorp No hosts found with target gohan of type glob
14:12 masterkorp am I missing anything ?
14:15 masterkorp oh, neverming
14:25 abednarik joined #salt
14:37 lompik joined #salt
14:41 TyrfingMjolnir joined #salt
14:45 otter768 joined #salt
14:47 subsignal joined #salt
14:48 linjan joined #salt
14:57 jaybocc2 joined #salt
15:05 linjan joined #salt
15:08 kusams joined #salt
15:24 peterd_ joined #salt
15:24 Ashald joined #salt
15:32 dayid joined #salt
15:32 dayid joined #salt
15:42 joyrida08 joined #salt
15:48 subsignal joined #salt
15:51 ALLmightySPIFF joined #salt
15:56 kusams joined #salt
15:59 justanotheruser joined #salt
16:01 dendazen joined #salt
16:01 masterkorp does Test=true work on salt-ssh ?
16:03 hasues joined #salt
16:04 honestly yes
16:07 hasues left #salt
16:08 masterkorp honestly: thanks
16:09 arif-ali hi all.
16:09 masterkorp and also, nice nick
16:09 masterkorp for moments i read "honestly, yes"
16:09 arif-ali I have been trying to get the ext_modules to work, but it's not finding the external module at all, I can't find and able to debug if it is being read or not
16:10 arif-ali I have specified extension_modules in master config, but still no luck, and and have also added to site-packages/salt/pillar, and still no luck. Any ideas from someone would be great
16:11 arif-ali I had it working for an hour 2 days ago, but can't figure out what the cause is now, -l debug and -l trace aren't giving much
16:33 abednarik joined #salt
16:38 tmclaugh[work] joined #salt
16:44 amcorreia joined #salt
16:45 tmclaugh[work] joined #salt
16:46 otter768 joined #salt
16:52 bryguy joined #salt
16:52 dustywusty joined #salt
16:52 Vye joined #salt
16:52 smkelly joined #salt
16:52 rideh joined #salt
16:52 kuromagi joined #salt
16:52 evilrob joined #salt
16:53 frew joined #salt
16:53 okfine joined #salt
16:53 jcockhren joined #salt
16:54 lompik joined #salt
16:55 pmcnabb joined #salt
16:56 GreatSnoopy joined #salt
16:57 qman__ joined #salt
16:57 jaybocc2 joined #salt
17:00 abednarik joined #salt
17:02 subsignal joined #salt
17:12 masterkorp Does gpg pillar data works with gpg keys with password?
17:12 masterkorp so that the password will be prompt when I launch the command?
17:13 intr1nsic joined #salt
17:13 xenoxaos joined #salt
17:20 colegatron joined #salt
17:21 dendazen left #salt
17:26 oeuftete joined #salt
17:28 justanotheruser joined #salt
17:29 dyasny joined #salt
17:32 masterkorp ok Test=true does not work in salt-ssh
17:32 ajw0100 joined #salt
17:35 masterkorp https://github.com/saltstack/salt/issues/30014
17:35 saltstackbot [#30014]title: Test modes does not work in salt-ssk | Running a command with salt: ``salt-ssh gohan state.sls email.opendkim Test=true`` Does actually run the commands in the system....
17:35 masterkorp opened an issue
17:36 masterkorp honestly: ok, it does not :p
17:36 oeuftete joined #salt
17:36 honestly huh?
17:37 masterkorp the command above did actually run the states
17:42 jaybocc2 joined #salt
17:43 honestly https://docs.saltstack.com/en/latest/ref/states/testing.html
17:43 honestly works exactly the same way in salt-ssh
17:43 jfindlay trouble_: it should be a ~6 month cycle.  This sort of talks about related topics, https://saltstack.com/product-support-lifecycle/
17:44 jfindlay with Beryllium we experimented with a 3 month cycle, but determined it was too much overhead
17:44 LotR joined #salt
17:48 kermit joined #salt
17:53 ALLmightySPIFF joined #salt
17:53 rotbeard joined #salt
17:58 rotbeard joined #salt
18:03 cswang_ joined #salt
18:18 slav0nic masterkorp, maybe test=True? i use it with highstate in salt-ssh without any issues
18:21 masterkorp slav0nic: let me try that
18:22 masterkorp that works
18:38 TTimo does salt uses it's own, sandboxed python interpreter?
18:38 TTimo I installed impacket, but salt-cloud still bails on me saying it's not installed
18:38 TTimo (for windows minions - https://docs.saltstack.com/en/latest/topics/cloud/windows.html)
18:40 jfindlay TTimo: yes, for windows minions
18:40 jfindlay under c:\salt
18:43 TTimo on the master I mean
18:43 ggoZ joined #salt
18:43 anmol joined #salt
18:44 TTimo I issued salt-cloud -p ec2_windows winz and eventually it says impacket needs to be installed (which it is, to the default python at least)
18:44 jfindlay the master should be using the standard system python
18:45 TTimo kk
18:46 jaybocc2 joined #salt
18:47 otter768 joined #salt
19:05 cberndt joined #salt
19:16 shaggy_surfer joined #salt
19:34 justanotheruser joined #salt
19:37 shadowsun joined #salt
19:47 slav0nic joined #salt
19:47 adamfeuer joined #salt
19:53 GothAck joined #salt
19:54 ALLmightySPIFF joined #salt
19:57 adamfeuer Hi all. I have a Salt masterless development problem - trying to develop a feature for Salt and test in masterless mode. But I keep getting an error running salt.highstate - "[DEBUG   ] Could not LazyLoad salt.highstate [DEBUG   ] Could not LazyLoad salt.highstate - 'salt.highstate' is not available."
19:58 adamfeuer I posted a stack overflow on it: http://stackoverflow.com/questions/34474606/setting-up-saltstack-for-local-masterless-development
19:58 abednarik joined #salt
19:58 whytewolf adamfeuer: just answered you in email. but the answer is basicly it is state.highstate, not salt.highstate
20:01 adamfeuer whytewolf: yes you are right. That works! Thank you. (Doh. Been looking at this for too long to see it myself I guess.)
20:02 whytewolf it happens. we have all been to the point of just a second pair of eyes are needed to cover what is just a simple mistake
20:07 adamfeuer Thanks! I'm back on track. :-)
20:08 whytewolf no problem, happy salting!
20:20 macker joined #salt
20:31 sinonick joined #salt
20:31 jaybocc2 joined #salt
20:42 justanotheruser joined #salt
20:43 brianfeister joined #salt
20:45 brianfei_ joined #salt
20:47 bVector_ joined #salt
20:48 otter768 joined #salt
20:48 tehsu joined #salt
20:49 OliverMT joined #salt
20:52 ajw0100 joined #salt
21:09 quasiben joined #salt
21:25 brianfeister joined #salt
21:31 brianfeister joined #salt
21:43 quasiben1 joined #salt
21:47 otter768 joined #salt
22:09 treaki joined #salt
22:14 nebuchadnezzar joined #salt
22:15 jaybocc2 joined #salt
22:50 cberndt joined #salt
22:56 ALLmightySPIFF joined #salt
23:01 dyasny joined #salt
23:11 Rumbles joined #salt
23:15 seblu joined #salt
23:23 colegatron joined #salt
23:38 abednarik joined #salt
23:39 mattiasr joined #salt
23:43 edrocks joined #salt
23:53 jaybocc2 joined #salt

| Channels | #salt index | Today | | Search | Google Search | Plain-Text | summary