Perl 6 - the future is here, just unevenly distributed

IRC log for #salt, 2016-04-30

| Channels | #salt index | Today | | Search | Google Search | Plain-Text | summary

All times shown according to UTC.

Time Nick Message
00:02 iggy gtmanfred: I was (a little late), salt doesn't really lend itself to having "one true way" to do stuff like that
00:04 lero joined #salt
00:04 edrocks joined #salt
00:08 dyasny_ joined #salt
00:10 aqua^c joined #salt
00:16 SheetiS joined #salt
00:22 pipps99 joined #salt
00:23 flowstate joined #salt
00:23 rem5 joined #salt
00:24 manji joined #salt
00:49 bb74352 joined #salt
00:54 BretFisher joined #salt
00:56 meekrab joined #salt
00:58 amcorreia joined #salt
01:10 Garo_ joined #salt
01:11 hrumph in salt what would be the best way to distribute a bunch of CA certificates to windows machines?
01:16 envintus joined #salt
01:16 kevinquinnyo hrumph: wish i could help you -- i don't manage windows machines (thank god).  I have my own question though for anyone -- how can i debug / troubleshoot a test -- I want to do something like:  print "____debug {0}".format(MagicMock(return_value="does not matter"))
01:17 kevinquinnyo in a unit test
01:17 hrumph kevinquinnyo, well in this case i'm not even sure that there's a set way to distribute CA certificate to linux machines either
01:19 hrumph well i see they've got some cert management stuff here but none of it looks windowsy
01:19 hrumph for win we really want to have a specific windows module
01:19 hrumph were we cam dp stiff like list certificates and import into the store
01:20 Slimmons Hey, can anyone who's dealt some with pkgrepo.managed give me some advice on what could be wrong here?  https://gist.github.com/johnsimmons/89bf37d8b0e97e74a84a8f3f2d6d1c44
01:22 racooper joined #salt
01:23 flowstate joined #salt
01:27 linjan_ joined #salt
01:27 spuder joined #salt
01:36 scottcrooks joined #salt
01:36 kevinquinnyo Slimmons: without your code, it's hard to help.  But obviously salt is ultimately trying to make an http request to http://repo.mongodb.org/apt/ubuntu/dists/trusty/multiverse/binary-amd64/Packages which results in a 404
01:36 kevinquinnyo Slimmons: show the code and i bet i can fix it
01:38 Slimmons the gist is all there is.  I'm just trying to emulate what's in "stuff.txt"
01:38 Slimmons it's just the install for mongodb
01:38 kevinquinnyo ahh i see
01:38 * kevinquinnyo scrolls down
01:40 hasues joined #salt
01:45 kevinquinnyo Slimmons: do you have a typo?  you have a space here:
01:46 kevinquinnyo - name: deb http://repo.mongodb.org/apt/ubuntu trusty/mongodb-org/3.0 multiverse
01:46 Slimmons no, it's no typo.  That's how it has it in the install instructions.  Also, the example setup for similar situations in the saltstack docs are the same.  https://docs.saltstack.com/en/latest/ref/states/all/salt.states.pkg.html
01:54 iceyao joined #salt
01:55 michelangelo joined #salt
02:01 kevinquinnyo Slimmons: does it work for you if you:
02:01 kevinquinnyo rm -f /etc/apt/sources.list.d/mongodb-org-3.0.list
02:02 kevinquinnyo then comment out the - dist trusty line
02:02 kevinquinnyo then run the state again
02:02 kevinquinnyo i think it might be a bug
02:02 Slimmons trying now
02:03 Slimmons I didn't comment out the trusty line, but it worked.  What was wrong?
02:04 kevinquinnyo hm
02:04 Slimmons I did delete that file though
02:05 kevinquinnyo now i wish i had asked you to cat /etc/apt/sources.list.d/mongodb-org-3.0.list first
02:05 Slimmons lol
02:05 Slimmons well, I can try it on a new minion, and see if it does the same thing the first time.
02:05 kevinquinnyo it still *feels* like a bug
02:05 kevinquinnyo cool
02:05 kevinquinnyo let me know, i'm curious
02:06 edrocks joined #salt
02:07 intr1nsic joined #salt
02:09 rem5 joined #salt
02:10 kevinquinnyo Slimmons: i think it is kind of a bug, because here's what i think happened with you.  You didn't do anything wrong (in your example), but you had a previously mangled /etc/apt/sources.list.d/mongodb-org-3.0.list from previous attempts.  For instance
02:11 kevinquinnyo if you change "- name: deb http://repo.mongodb.org/apt/ubuntu trusty/mongodb-org/3.0 multiverse"
02:11 kevinquinnyo to - name: deb http://repo.mongodb.org/apt/ubuntu INTENTIONALLY BREAK IT trusty/mongodb-org/3.0 multiverse
02:12 kevinquinnyo then try to run the correct version again, it will fail, because it wrote the garbage version to the file
02:12 kevinquinnyo it just appends
02:13 xenoxaos joined #salt
02:13 kevinquinnyo it seems to happily append garbage
02:14 Slimmons that's great.  Would it do the same thing if I had the wrong key in the keyid you think?
02:14 kevinquinnyo i would call that a bug because if you are defining what /etc/apt/sources.list.d/mongodb-org-3.0.list *should be*, it should by default *replace* that file, as opposed to appending to it (i think)
02:14 kevinquinnyo not sure
02:15 kevinquinnyo it may fail upstream on that, i'm not sure how the module works
02:15 kevinquinnyo that's probably worth opening an issue on
02:18 kevinquinnyo i mean probably worth opening an issue on the problem of 'pkgrepo.managed' appending garbage and then failing, instead of just rewriting it
02:19 tpaul joined #salt
02:22 rfk joined #salt
02:23 flowstate joined #salt
02:25 meekrab joined #salt
02:26 Slimmons well, after I tried on a new minion, I got this bug.  https://github.com/saltstack/salt/issues/26882
02:26 saltstackbot [#26882]title: `npm.bootstrap` fails when NPM is not installed | Using the state `npm.bootstrap` fails when NPM isn't installed yet:...
02:27 Slimmons I'm on 2015.5.3
02:28 Slimmons lol, i'm not having a very lucky night
02:33 Slimmons what's the proper way to upgrade from 2015.5, to 2015.8 on ubuntu.  I would think it would be to add the ppa, but there doesn't appear to be one for 2015.8
02:33 Slimmons and the upgrading salt section is......literally a sentence that doesn't tell you how to do it. https://docs.saltstack.com/en/latest/topics/installation/index.html#upgrading-salt
02:34 Slimmons not judging, just hoping it's somewhere else
02:38 spuder joined #salt
02:41 beardedeagle joined #salt
02:50 flowstate joined #salt
02:52 XenophonF Slimmons: IIRC they stopped using the PPA.
02:52 XenophonF Same on RHEL/CentOS - deprecated the COPR
02:52 XenophonF see http://repo.saltstack.com/ for packages
02:53 XenophonF salt-formula has a salt.repo SLS that will set them up for you on Debian & RedHat osfamily
02:53 XenophonF then just apt-get update && apt-get upgrade
02:53 XenophonF do the master first, then the minions
02:56 writtenoff joined #salt
03:00 damon-atkins joined #salt
03:03 tristianc_ joined #salt
03:04 newellista joined #salt
03:06 Slimmons thanks, I've been looking for that for a bit now
03:07 jvblasco joined #salt
03:08 cachedout joined #salt
03:09 hasues left #salt
03:12 spuder joined #salt
03:13 newellista joined #salt
03:17 bb74352 joined #salt
03:17 jeddi joined #salt
03:41 meekrab joined #salt
03:47 subsignal joined #salt
03:52 Slimmons kevinquinnyo: you were correct.  it wrote the garbage value into the file, and then when I corrected it, it just appended to the end of the file, and stays broken until I delete the file.  I'll open an issue, and post it here.
04:06 estahn joined #salt
04:09 edrocks joined #salt
04:11 meekrab joined #salt
04:16 Slimmons kevinquinnyo: https://github.com/saltstack/salt/issues/32960
04:16 saltstackbot [#32960]title: pkgrepo.managed doesn't work if junk data is sent to the minions sources.list first. | ### Description of Issue/Question...
04:22 amy_ joined #salt
04:43 macheck joined #salt
04:51 viq joined #salt
04:52 ionjon joined #salt
04:53 ionjon Does anyone know of salt cloud supports the new-ish azure arm (azure resource manager) style vms?
04:54 ionjon It's not totally clear from the docs, but terminology like cloud service (which is a pre-arm concept) is used, which makes me think no
04:58 aequitas154 joined #salt
05:05 punkoivan joined #salt
05:06 shadowbeast joined #salt
05:23 sauvin joined #salt
05:47 amy_ joined #salt
05:47 slav0nic joined #salt
05:58 hrumph i've posted two new issues
05:59 hrumph https://github.com/saltstack/salt/issues/32961
05:59 saltstackbot [#32961]title: Windows implementation of pkg.installed does not work with version numbers if included with items in the pkgs paramater list | ### Description of Issue/Question...
05:59 hrumph https://github.com/saltstack/salt/issues/32962
05:59 saltstackbot [#32962]title: Problem with winrepo and pkg.installed | ### Description of Issue/Question...
06:01 punkoivan joined #salt
06:02 punkoivan joined #salt
06:11 aqua^c joined #salt
06:12 edrocks joined #salt
06:12 Slimmons joined #salt
06:16 Slimmons I'm about to head to sleep, but I'll check this in the morning.  Anybody have any idea why this archive extraction would keep failing?  The sourc extracts to a directory called bundle, which is why the if_missing is defined that way.  It's acting like the hash is wrong, but that is the correct hash for the source file rocket.chat.tgz.  https://gist.github.com/Slimmons/67dee8111db8e6e38eefe7d91c00c3a6
06:17 damona joined #salt
06:18 AndreasLutro I prefer just using cmd.run with wget -nv and tar xf
06:20 muep_ Slimmons: is the source parameter supposed to have an -o item in the end?
06:20 macheck left #salt
06:20 meekrab joined #salt
06:20 macheck joined #salt
06:21 estahn joined #salt
06:23 flowstate joined #salt
06:24 meekrab joined #salt
06:29 iggy Slimmons: for the pkgrepo thing, clean_file
06:39 _beardedeagle joined #salt
06:43 subsignal joined #salt
07:00 Ayo joined #salt
07:02 markm__ joined #salt
07:24 flowstate joined #salt
07:34 Miouge joined #salt
07:35 rbjorkli1 joined #salt
07:49 viq joined #salt
07:54 mohger joined #salt
08:05 mohg joined #salt
08:13 edrocks joined #salt
08:19 Trauma_ joined #salt
08:20 estahn joined #salt
08:23 flowstate joined #salt
08:44 cyborg-one joined #salt
08:46 subsignal joined #salt
08:57 rmnuvg joined #salt
09:09 lero joined #salt
09:09 Fiber^ joined #salt
09:09 estahn joined #salt
09:18 catpig joined #salt
09:24 flowstate joined #salt
09:35 colttt joined #salt
09:42 viq_ joined #salt
09:42 TyrfingMjolnir joined #salt
10:01 jagguli joined #salt
10:11 druonysus joined #salt
10:11 orion Does anyone know what the cause of this error is?: "An importable pip module is required but could not be found on your system. This usually means that the system's pip package is not installed properly." I can run "/usr/bin/pip" from the host and it works correctly.
10:15 ronnix joined #salt
10:16 edrocks joined #salt
10:23 flowstate joined #salt
10:23 ronnix joined #salt
10:23 AndreasLutro orion: python -c 'import pip' ? check that pip was installed for the same python version salt is running under
10:25 orion AndreasLutro: No error with that command.
10:29 colttt joined #salt
10:31 _viq joined #salt
10:35 lero joined #salt
10:38 slav0nic joined #salt
10:46 druonysus joined #salt
10:48 subsignal joined #salt
10:50 CeBe joined #salt
10:56 west575 joined #salt
11:02 sjorge joined #salt
11:09 mrueg joined #salt
11:12 druonysus joined #salt
11:22 CeBe joined #salt
11:23 flowstate joined #salt
11:26 s_kunk joined #salt
11:29 mowntan joined #salt
11:30 druonysus joined #salt
11:39 campbellm joined #salt
11:41 amy_ joined #salt
11:44 estahn joined #salt
11:44 viq_ joined #salt
11:58 Jimlad_ joined #salt
11:58 hillna_ joined #salt
11:59 chamunks- joined #salt
11:59 wryfi_ joined #salt
11:59 rickflare2 joined #salt
12:00 Antiarc_ joined #salt
12:02 N-Mi joined #salt
12:02 N-Mi joined #salt
12:04 wmp joined #salt
12:04 M-MadsRC2 joined #salt
12:05 capri- joined #salt
12:08 Gareth joined #salt
12:08 Cidan joined #salt
12:11 dmaiocchi joined #salt
12:12 gmoro joined #salt
12:14 dkrae joined #salt
12:14 bowhunter joined #salt
12:14 alvinstarr joined #salt
12:19 edrocks joined #salt
12:32 lero joined #salt
12:50 subsignal joined #salt
12:54 meekrab joined #salt
12:59 KingJ joined #salt
13:00 viq_ joined #salt
13:00 amcorreia joined #salt
13:03 west575 joined #salt
13:05 mjmasn joined #salt
13:07 mjmasn Hey all, anyone know how to change the default shell for cmd.run on the salt-minion? I know salt-minion looks for SHELL env var but can't work out where to set that in such a way that service salt-minion start will pick it up...
13:08 mjmasn I'm running ubuntu 14.04, and latest salt-minion
13:12 mjmasn It's defaulting to /bin/sh and I want it to use /bin/bash. 4 of my servers are showing bash but 1 is using /bin/sh (dash) and I get lots of not found errors e.g. /bin/sh: 1: npm: not found. I could add shell:/bin/bash to every command but that seems silly
13:13 AndreasLutro switching to bash isn't going to fix "/bin/sh: 1: npm: not found" but cmd.run has a shell arg
13:21 rem5 joined #salt
13:22 lero joined #salt
13:27 mjmasn node/npm is installed with nvm so it's installed locally not globally, so it does work if I explicitly set the shell on each command but I just wanted to know how to change the default
13:29 Ayo_ joined #salt
13:31 Muchoz joined #salt
13:33 cpowell joined #salt
13:41 viq__ joined #salt
13:44 viq joined #salt
13:50 mowntan joined #salt
13:50 mowntan joined #salt
13:53 NEWEN joined #salt
13:54 NEWEN left #salt
14:00 aqua^c joined #salt
14:02 campbellm joined #salt
14:04 newjersey joined #salt
14:16 iceyao joined #salt
14:16 tharkun joined #salt
14:17 subsignal joined #salt
14:18 damona_ joined #salt
14:22 mjmasn joined #salt
14:23 mjmasn Fixed it, I had tried putting shell: /bin/bash in /etc/salt/minion but it needed to be grains: shell: /bin/bash
14:25 mohae joined #salt
14:43 flowstate joined #salt
14:44 Muchoz_ joined #salt
14:53 rem5 joined #salt
15:06 viq_ joined #salt
15:13 skeezix-hf joined #salt
15:19 skeezix-hf joined #salt
15:22 flowstate joined #salt
15:25 CeBe joined #salt
15:35 tpaul joined #salt
15:37 estahn joined #salt
15:46 johnkeates joined #salt
15:48 amy_ joined #salt
15:57 iceyao joined #salt
15:59 elsysops joined #salt
16:07 amcorreia joined #salt
16:14 amy_ joined #salt
16:15 Ayo joined #salt
16:16 subsignal joined #salt
16:17 punkoivan joined #salt
16:22 flowstate joined #salt
16:23 edrocks joined #salt
16:25 s0undt3ch joined #salt
16:41 dendazen joined #salt
16:48 lionel joined #salt
16:58 meekrab joined #salt
17:00 keldwud_ joined #salt
17:01 meekrab joined #salt
17:02 ageorgop joined #salt
17:17 amy_ joined #salt
17:18 meekrab joined #salt
17:22 flowstate joined #salt
17:25 west575 joined #salt
17:25 rem5 joined #salt
17:29 amcorreia joined #salt
17:33 punkoivan left #salt
17:34 cpowell joined #salt
17:36 rem5 joined #salt
17:42 goal hi, is it possible to see the rendered output of a pillar sls? trying to find out why a render is failing with 'Rendering SLS .. failed', there's no reason or other output given in the master log
17:43 perfectsine joined #salt
17:59 lero joined #salt
18:03 viq_ joined #salt
18:12 perfectsine joined #salt
18:13 amcorreia joined #salt
18:21 subsignal joined #salt
18:21 flowstate joined #salt
18:26 edrocks joined #salt
18:28 cachedout joined #salt
18:38 cachedout joined #salt
18:39 meekrab joined #salt
18:52 ajspa joined #salt
18:52 hexa- are relative imports still working on 2015.8.8?
18:52 hexa- we have
18:53 hexa- domains/ffda.sls and host/gw01/domains/ffda.sls
18:53 damona_ joined #salt
18:53 hexa- and in hosts/gw01/init.sls we include .domains/ffda.sls
18:53 hexa- it will not include with a relative path though, find the top-most instead
18:55 rem5 joined #salt
19:02 hexa- https://github.com/saltstack/salt/issues/8875
19:02 saltstackbot [#8875]title: Support relative includes for pillar | The dot notation that's supported for relative includes in state files  (`include: - .other`) doesn't seem to work for pillar. Would be just as useful there.
19:02 hexa- only in pillars <.<
19:06 AndreasLutro you might not want to use includes in pillars regardless - the order of execution is completely out of your control
19:06 hexa- ok thanks
19:15 Ayo joined #salt
19:17 cachedout joined #salt
19:18 edrocks joined #salt
19:20 brianfeister joined #salt
19:21 flowstate joined #salt
19:22 lero joined #salt
19:22 subsignal joined #salt
19:25 kojiro joined #salt
19:38 rem5 joined #salt
19:38 CeBe joined #salt
19:42 Slimmons muep_: that was it.  Thanks for the help.  It didn't like passing an argument (which makes total sense...should have seen that earlier.)
19:45 edrocks joined #salt
19:45 linjan joined #salt
19:49 mapu joined #salt
20:03 SeaPhor joined #salt
20:09 SeaPhor I can't remember the nick of the person that gave me the link to the "Getting Started" guide, but Thanks- started it this morning and its a decent tutorial/walk-through of the basics... I hope there's an advanced tutorial out there too... so far the only down-side is having to use ubuntu for the VMs :D :P
20:13 meekrab joined #salt
20:14 nerdsville joined #salt
20:15 nerdsville Hello all, is there a way to specify that I want to install nginx ~= 1.8 with the pkg.installed module with the target platform being centos? I can get it to install 1.8, but the problem is it still errors out because the version number is slightly different (1.8.1-1.el7)
20:17 west575 joined #salt
20:23 flowstate joined #salt
20:28 edrocks_ joined #salt
20:50 Kelsar joined #salt
20:58 Miouge joined #salt
21:00 TaiSHi Does anyone have issues when using salt-cloud where salt-bootstrap fails to get apt locks?
21:00 TaiSHi (and doesn't wait for them either)
21:10 SeaPhor nerdsville, I'm new here, and I'm going thru the demo, and this may apply to your question- not sure but just trying to help--   {% if grains['os_family'] == 'RedHat' %}         apache: httpd        git: git       {% elif grains['os_family'] == 'Debian' %}        apache: apache2     git: git-core     {% endif %}
21:11 SeaPhor from https://docs.saltstack.com/en/getstarted/config/jinja.html
21:12 mohae joined #salt
21:15 nerdsville left #salt
21:22 flowstate joined #salt
21:22 Muchoz joined #salt
21:24 subsignal joined #salt
21:25 rem5 joined #salt
21:26 subsigna_ joined #salt
21:36 cpowell joined #salt
21:39 Sam__ joined #salt
21:40 Sam__ Hi, I'm having some difficulties setting up the salt Dev enviroment. When I vagrant up it will not connect to the master
22:12 rem5 joined #salt
22:20 kevinquinnyo joined #salt
22:21 Hivlaher joined #salt
22:21 flowstate joined #salt
22:21 SeaPhor you mean the "demo" environment?
22:29 Sam__ yes
22:30 edrocks joined #salt
22:38 zenlot6 joined #salt
22:50 SeaPhor I had issues when I tried it at work, but the corp firewall wouldnt let it get the packages it needed, but worked fine at home
23:11 campbellm joined #salt
23:12 mavhq joined #salt
23:21 flowstate joined #salt
23:21 Sam__ I'm at my home. No firewall.
23:22 Sam__ when I do vagrant ssh master it says  master: Warning: Remote connection disconnect. Retrying...
23:22 Sam__ and then eventually times out.
23:23 SeaPhor open Virtual box and see if its running OR do ps -ef | grep -i vbox
23:24 SeaPhor were there any errors when you did "vagrant up" ??
23:28 mowntan joined #salt
23:32 i90rr joined #salt
23:38 subsignal joined #salt
23:43 elsysops joined #salt
23:55 brianfeister joined #salt

| Channels | #salt index | Today | | Search | Google Search | Plain-Text | summary