Perl 6 - the future is here, just unevenly distributed

IRC log for #webwork, 2014-08-14

| Channels | #webwork index | Today | | Search | Google Search | Plain-Text | summary

All times shown according to UTC.

Time Nick Message
03:40 soumya joined #webwork
03:55 ilbot3 joined #webwork
03:55 Topic for #webwork is now WeBWorK (http://webwork.maa.org) is an open-source online homework system for math and sciences courses. WeBWorK is supported by the MAA and the NSF. | Release notes: http://goo.gl/Ry5HN | Channel logged at http://goo.gl/jELTn
04:10 ilbot3 joined #webwork
04:10 Topic for #webwork is now WeBWorK (http://webwork.maa.org) is an open-source online homework system for math and sciences courses. WeBWorK is supported by the MAA and the NSF. | Release notes: http://goo.gl/Ry5HN | Channel logged at http://goo.gl/jELTn
15:32 soumya joined #webwork
16:55 aubreyja joined #webwork
16:55 aubreyja joined #webwork
17:35 goehle joined #webwork
17:35 goehle hey aubreyja
17:35 goehle figure out your problem?
17:49 aubreyja hey goehle - no, but it ww_install worked fine (ish) on a fresh debian
17:50 aubreyja There are a couple of tasks to finish to have it fully install ww3, but it did work after that
17:50 aubreyja it's really strange: (1) works fine on master (2) switching to ww3 breaks it
17:51 aubreyja even redid the config files and everything
17:51 goehle yeah
17:51 goehle thats wierd
17:51 aubreyja next I'm going to just blow out the whole install and start over from scratch.
17:51 aubreyja with ww_install
17:52 goehle do you have courses you need to save?
17:52 aubreyja no, it just got set up in spring before I left for Italy and I haven't done anything with it yet.
17:53 aubreyja going to run my online course and my proofs class on it this semester though
17:53 goehle then a reinstall is probably easiest.  I'm sure you could find out what was going wrong if you went through with a fine toothed comb.
17:53 aubreyja yeah, probably, but classes are starting soon...
17:53 goehle have you double checked that the apache process is actually reastarting all o f the http things
17:53 goehle maybe one is surviving somehow and thats causing the issue
17:53 goehle seems unlikely
17:53 goehle but its such a wierd issue
17:54 aubreyja could be - wouldn't be hard to check this anyway
17:59 aubreyja well, here goes nothing
18:09 aubreyja well...uh...not sure yet, but it might have been a prerequisites issue...
18:09 goehle like apr is missing?
18:10 aubreyja no, when I started install_webwork.sh I expected it to not install any prereqs, but it seemed to get a few Dancer things from cpan
18:10 aubreyja thing is, I definitely ran install_prerequisites.sh yesterday
18:10 goehle it oculd be that the online notes were missing something
18:11 aubreyja it's still going so I'll know in a bit if this worked
18:24 aubreyja goehle - bam!
18:25 goehle nice :)
18:25 aubreyja yeah, must have been missing dancer stuff. Or something else. Whatevs.
18:25 goehle annoying that there isn't an easier way to diagnose that
18:25 goehle although I supppose its good to know that you can always run prerequisites
18:25 goehle just to be sure
18:26 aubreyja yeah, thought I did that, but there was clearly stuff installed when I reran it today
18:26 goehle mysterious

| Channels | #webwork index | Today | | Search | Google Search | Plain-Text | summary